[v9,0/5] add new helper for wait scheme

Message ID 20211101060007.2632418-1-feifei.wang2@arm.com (mailing list archive)


Feifei Wang Nov. 1, 2021, 6 a.m. UTC
  Add new helper for wait scheme, and apply this new definitions into
lib to replace rte_pause.

1. use macro to create new wait scheme (Stephen)

1. delete unnecessary bug fix in bpf (Konstantin)

1. put size into the macro body (Konstantin)
2. replace assert with BUILD_BUG_ON (Stephen)
3. delete unnecessary compiler barrier for bpf (Konstantin)

1. 'size' is not the parameter (Konstantin)
2. put () around macro parameters (Konstantin)
3. fix some original typo issue (Jerin)
4. swap 'rte_wait_event' parameter location (Jerin)
5. add new macro '__LOAD_EXC'
6. delete 'undef' to prevent compilation warning

1. fix patch style check warning
2. delete 'bpf' patch due to 'const' limit

1. add __RTE_ARM to to fix the namespace (Jerin)
2. use 'uintptr_t *' in mcslock for different
architecture(32/64) (Mattias)
3. add a new pointer 'next' in mcslock to fix
compiler issue
4. add bpf patch and use 'uintptr_t' to fix const
discard warning (Konstantin)

1. add __LOAD_EXC_128 (Jerin)
2. use BUILD_BUG_ON to replace assert (Jerin)

1. rename 'wait_event' as 'wait_until' (David)
2. change commit message (David)

Feifei Wang (5):
  eal: add a new generic helper for wait scheme
  pflock: use wait until scheme for read pflock
  mcslock: use wait until scheme for mcslock
  bpf: use wait until scheme for Rx/Tx iteration
  distributor: use wait until scheme

 lib/bpf/bpf_pkt.c                        |   9 +-
 lib/distributor/rte_distributor_single.c |  10 +-
 lib/eal/arm/include/rte_pause_64.h       | 202 ++++++++++++++---------
 lib/eal/include/generic/rte_mcslock.h    |   5 +-
 lib/eal/include/generic/rte_pause.h      |  29 ++++
 lib/eal/include/generic/rte_pflock.h     |   4 +-
 6 files changed, 166 insertions(+), 93 deletions(-)