[dpdk-dev,1/3] librte_ether: add RTE_ETH_FDIR_OTHER for flow director behavior

Message ID 1443536800-13269-2-git-send-email-andrey.chilikin@intel.com (mailing list archive)
State Superseded, archived
Headers

Commit Message

Chilikin, Andrey Sept. 29, 2015, 2:26 p.m. UTC
  Add new flow director behavior RTE_ETH_FDIR_OTHER to assign a queue by other filters

Signed-off-by: Andrey Chilikin <andrey.chilikin@intel.com>
---
 lib/librte_ether/rte_eth_ctrl.h |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)
  

Comments

Bruce Richardson Sept. 29, 2015, 2:38 p.m. UTC | #1
On Tue, Sep 29, 2015 at 03:26:38PM +0100, Andrey Chilikin wrote:
> Add new flow director behavior RTE_ETH_FDIR_OTHER to assign a queue by other filters
> 
> Signed-off-by: Andrey Chilikin <andrey.chilikin@intel.com>
> ---
>  lib/librte_ether/rte_eth_ctrl.h |    1 +
>  1 files changed, 1 insertions(+), 0 deletions(-)
> 
> diff --git a/lib/librte_ether/rte_eth_ctrl.h b/lib/librte_ether/rte_eth_ctrl.h
> index 26b7b33..3acf501 100644
> --- a/lib/librte_ether/rte_eth_ctrl.h
> +++ b/lib/librte_ether/rte_eth_ctrl.h
> @@ -417,6 +417,7 @@ struct rte_eth_fdir_input {
>  enum rte_eth_fdir_behavior {
>  	RTE_ETH_FDIR_ACCEPT = 0,
>  	RTE_ETH_FDIR_REJECT,
> +	RTE_ETH_FDIR_OTHER,
>  };
>  
>  /**
> -- 
> 1.7.4.1
> 
Is "OTHER" meant to be a "NOOP" or a generic hold-all for a set of other possible
behaviours. From the description, I would assume NOOP - in which case would
RTE_ETH_FDIR_NOOP not be a better name?

/Bruce
  
Chilikin, Andrey Sept. 29, 2015, 2:48 p.m. UTC | #2
> -----Original Message-----
> From: Richardson, Bruce
> Sent: Tuesday, September 29, 2015 3:38 PM
> To: Chilikin, Andrey
> Cc: dev@dpdk.org
> Subject: Re: [dpdk-dev] [PATCH 1/3] librte_ether: add RTE_ETH_FDIR_OTHER
> for flow director behavior
> 
> On Tue, Sep 29, 2015 at 03:26:38PM +0100, Andrey Chilikin wrote:
> > Add new flow director behavior RTE_ETH_FDIR_OTHER to assign a queue by
> > other filters
> >
> > Signed-off-by: Andrey Chilikin <andrey.chilikin@intel.com>
> > ---
> >  lib/librte_ether/rte_eth_ctrl.h |    1 +
> >  1 files changed, 1 insertions(+), 0 deletions(-)
> >
> > diff --git a/lib/librte_ether/rte_eth_ctrl.h
> > b/lib/librte_ether/rte_eth_ctrl.h index 26b7b33..3acf501 100644
> > --- a/lib/librte_ether/rte_eth_ctrl.h
> > +++ b/lib/librte_ether/rte_eth_ctrl.h
> > @@ -417,6 +417,7 @@ struct rte_eth_fdir_input {  enum
> > rte_eth_fdir_behavior {
> >  	RTE_ETH_FDIR_ACCEPT = 0,
> >  	RTE_ETH_FDIR_REJECT,
> > +	RTE_ETH_FDIR_OTHER,
> >  };
> >
> >  /**
> > --
> > 1.7.4.1
> >
> Is "OTHER" meant to be a "NOOP" or a generic hold-all for a set of other
> possible behaviours. From the description, I would assume NOOP - in which
> case would RTE_ETH_FDIR_NOOP not be a better name?
> 
> /Bruce
"NOOP" sounds like no operation at all, but FD still performs matching and extracts flexible payload to the RX descriptor, it only skips queue assignment which is done by other filters with lower priority. Maybe RTE_ETH_FDIR_PASSTHRU?

Regards,
Andrey
  
Bruce Richardson Sept. 29, 2015, 2:53 p.m. UTC | #3
On Tue, Sep 29, 2015 at 03:48:32PM +0100, Chilikin, Andrey wrote:
> > -----Original Message-----
> > From: Richardson, Bruce
> > Sent: Tuesday, September 29, 2015 3:38 PM
> > To: Chilikin, Andrey
> > Cc: dev@dpdk.org
> > Subject: Re: [dpdk-dev] [PATCH 1/3] librte_ether: add RTE_ETH_FDIR_OTHER
> > for flow director behavior
> > 
> > On Tue, Sep 29, 2015 at 03:26:38PM +0100, Andrey Chilikin wrote:
> > > Add new flow director behavior RTE_ETH_FDIR_OTHER to assign a queue by
> > > other filters
> > >
> > > Signed-off-by: Andrey Chilikin <andrey.chilikin@intel.com>
> > > ---
> > >  lib/librte_ether/rte_eth_ctrl.h |    1 +
> > >  1 files changed, 1 insertions(+), 0 deletions(-)
> > >
> > > diff --git a/lib/librte_ether/rte_eth_ctrl.h
> > > b/lib/librte_ether/rte_eth_ctrl.h index 26b7b33..3acf501 100644
> > > --- a/lib/librte_ether/rte_eth_ctrl.h
> > > +++ b/lib/librte_ether/rte_eth_ctrl.h
> > > @@ -417,6 +417,7 @@ struct rte_eth_fdir_input {  enum
> > > rte_eth_fdir_behavior {
> > >  	RTE_ETH_FDIR_ACCEPT = 0,
> > >  	RTE_ETH_FDIR_REJECT,
> > > +	RTE_ETH_FDIR_OTHER,
> > >  };
> > >
> > >  /**
> > > --
> > > 1.7.4.1
> > >
> > Is "OTHER" meant to be a "NOOP" or a generic hold-all for a set of other
> > possible behaviours. From the description, I would assume NOOP - in which
> > case would RTE_ETH_FDIR_NOOP not be a better name?
> > 
> > /Bruce
> "NOOP" sounds like no operation at all, but FD still performs matching and 
> extracts flexible payload to the RX descriptor, it only skips queue assignment
> which is done by other filters with lower priority. Maybe RTE_ETH_FDIR_PASSTHRU?
> 
> Regards,
> Andrey

PASSTHRU seems good to me. It's clearer than "OTHER" anyway :-)

/Bruce
  

Patch

diff --git a/lib/librte_ether/rte_eth_ctrl.h b/lib/librte_ether/rte_eth_ctrl.h
index 26b7b33..3acf501 100644
--- a/lib/librte_ether/rte_eth_ctrl.h
+++ b/lib/librte_ether/rte_eth_ctrl.h
@@ -417,6 +417,7 @@  struct rte_eth_fdir_input {
 enum rte_eth_fdir_behavior {
 	RTE_ETH_FDIR_ACCEPT = 0,
 	RTE_ETH_FDIR_REJECT,
+	RTE_ETH_FDIR_OTHER,
 };
 
 /**