new file mode 100644
@@ -0,0 +1,7 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Luca Boccassi <bluca@debian.org>
+
+drivers = ['null']
+
+config_flag_fmt = 'RTE_LIBRTE_@0@_PMD'
+driver_name_fmt = 'rte_pmd_@0@'
new file mode 100644
@@ -0,0 +1,7 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Luca Boccassi <bluca@debian.org>
+
+deps += ['bbdev', 'bus_vdev', 'ring']
+name = 'bbdev_null'
+allow_experimental_apis = true
+sources = files('bbdev_null.c')
@@ -9,6 +9,7 @@ driver_classes = ['common',
'crypto', # depends on common, bus and mempool (net in future).
'compress', # depends on common, bus, mempool.
'event', # depends on common, bus, mempool and net.
+ 'baseband', # depends on common and bus.
'raw'] # depends on common, bus, mempool, net and event.
default_cflags = machine_args
Signed-off-by: Luca Boccassi <bluca@debian.org> --- drivers/baseband/meson.build | 7 +++++++ drivers/baseband/null/meson.build | 7 +++++++ drivers/meson.build | 1 + 3 files changed, 15 insertions(+) create mode 100644 drivers/baseband/meson.build create mode 100644 drivers/baseband/null/meson.build