[v2,4/4] build: install igb_uio kernel module when building with Meson

Message ID 20180831104154.20938-4-bluca@debian.org (mailing list archive)
State Superseded, archived
Delegated to: Thomas Monjalon
Headers
Series [v2,1/4] build: include missing hypervisor files in Meson build |

Checks

Context Check Description
ci/checkpatch success coding style OK
ci/Intel-compilation success Compilation OK

Commit Message

Luca Boccassi Aug. 31, 2018, 10:41 a.m. UTC
  Install in $kerneldir/../extra/dpdk. Usually $kerneldir should something
like: /lib/modules/$kver/build, so this directory will match the default
one used by legacy makefiles.

Fixes: a52f4574f798 ("igb_uio: build with meson")

Signed-off-by: Luca Boccassi <bluca@debian.org>
---
v2: fixed DEST_DIR in option help text

 kernel/linux/igb_uio/meson.build | 2 ++
 meson_options.txt                | 2 +-
 2 files changed, 3 insertions(+), 1 deletion(-)
  

Comments

Bruce Richardson Aug. 31, 2018, 11:06 a.m. UTC | #1
On Fri, Aug 31, 2018 at 11:41:54AM +0100, Luca Boccassi wrote:
> Install in $kerneldir/../extra/dpdk. Usually $kerneldir should something
> like: /lib/modules/$kver/build, so this directory will match the default
> one used by legacy makefiles.
> 
> Fixes: a52f4574f798 ("igb_uio: build with meson")
> 
> Signed-off-by: Luca Boccassi <bluca@debian.org>
> ---

Acked-by: Bruce Richardson <bruce.richardson@intel.com>
  

Patch

diff --git a/kernel/linux/igb_uio/meson.build b/kernel/linux/igb_uio/meson.build
index 71ed2e7a85..f5a9d5ccf3 100644
--- a/kernel/linux/igb_uio/meson.build
+++ b/kernel/linux/igb_uio/meson.build
@@ -15,4 +15,6 @@  custom_target('igb_uio',
 			'/../../../lib/librte_eal/common/include',
 		'modules'],
 	depends: mkfile,
+	install: true,
+	install_dir: kernel_dir + '/../extra/dpdk',
 	build_by_default: get_option('enable_kmods'))
diff --git a/meson_options.txt b/meson_options.txt
index c843278587..f20887212a 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -7,7 +7,7 @@  option('examples', type: 'string', value: '',
 option('include_subdir_arch', type: 'string', value: '',
 	description: 'subdirectory where to install arch-dependent headers')
 option('kernel_dir', type: 'string', value: '',
-	description: 'path to the kernel for building kernel modules')
+	description: 'path to the kernel for building kernel modules, they will be installed in $DEST_DIR/$kernel_dir/../extra/dpdk')
 option('lib_musdk_dir', type: 'string', value: '',
 	description: 'path to the MUSDK library installation directory')
 option('machine', type: 'string', value: 'native',