diff mbox series

doc: add note on build issues with gcc < 5.0

Message ID 1581959575-263324-1-git-send-email-pablo.de.lara.guarch@intel.com (mailing list archive)
State Accepted, archived
Delegated to: Thomas Monjalon
Headers show
Series doc: add note on build issues with gcc < 5.0 | expand

Checks

Context Check Description
ci/Intel-compilation success Compilation OK
ci/travis-robot warning Travis build: failed
ci/checkpatch success coding style OK

Commit Message

De Lara Guarch, Pablo Feb. 17, 2020, 5:12 p.m. UTC
The following crypto PMDs use the Intel Multi-buffer library:
- AESNI MB PMD
- AESNI GCM PMD
- ZUC PMD
- KASUMI PMD
- SNOW3G PMD

When this library is built with gcc < 5.0, it might throw
some compilation issues. A workaround has been added in the
repo of this library, so a note on this has been added
to the documentation of these PMDs.

Signed-off-by: Pablo de Lara <pablo.de.lara.guarch@intel.com>
---
 doc/guides/cryptodevs/aesni_gcm.rst | 7 +++++++
 doc/guides/cryptodevs/aesni_mb.rst  | 6 ++++++
 doc/guides/cryptodevs/kasumi.rst    | 6 ++++++
 doc/guides/cryptodevs/snow3g.rst    | 6 ++++++
 doc/guides/cryptodevs/zuc.rst       | 6 ++++++
 5 files changed, 31 insertions(+)

Comments

Mcnamara, John Feb. 18, 2020, 8:30 a.m. UTC | #1
> -----Original Message-----
> From: De Lara Guarch, Pablo <pablo.de.lara.guarch@intel.com>
> Sent: Monday, February 17, 2020 5:13 PM
> To: Mcnamara, John <john.mcnamara@intel.com>
> Cc: dev@dpdk.org; De Lara Guarch, Pablo <pablo.de.lara.guarch@intel.com>
> Subject: [PATCH] doc: add note on build issues with gcc < 5.0
> 
> The following crypto PMDs use the Intel Multi-buffer library:
> - AESNI MB PMD
> - AESNI GCM PMD
> - ZUC PMD
> - KASUMI PMD
> - SNOW3G PMD
> 
> When this library is built with gcc < 5.0, it might throw some compilation
> issues. A workaround has been added in the repo of this library, so a note
> on this has been added to the documentation of these PMDs.


Acked-by: John McNamara <john.mcnamara@intel.com>
Thomas Monjalon Feb. 21, 2020, 11:26 p.m. UTC | #2
18/02/2020 09:30, Mcnamara, John:
> > From: De Lara Guarch, Pablo <pablo.de.lara.guarch@intel.com>
> > 
> > The following crypto PMDs use the Intel Multi-buffer library:
> > - AESNI MB PMD
> > - AESNI GCM PMD
> > - ZUC PMD
> > - KASUMI PMD
> > - SNOW3G PMD
> > 
> > When this library is built with gcc < 5.0, it might throw some compilation
> > issues. A workaround has been added in the repo of this library, so a note
> > on this has been added to the documentation of these PMDs.
> 
> Acked-by: John McNamara <john.mcnamara@intel.com>

Applied, thanks
diff mbox series

Patch

diff --git a/doc/guides/cryptodevs/aesni_gcm.rst b/doc/guides/cryptodevs/aesni_gcm.rst
index a25b631..1e8cdec 100644
--- a/doc/guides/cryptodevs/aesni_gcm.rst
+++ b/doc/guides/cryptodevs/aesni_gcm.rst
@@ -50,6 +50,13 @@  can be downloaded in `<https://github.com/01org/intel-ipsec-mb/archive/v0.53.zip
     make
     make install
 
+.. note::
+
+   Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.
+   If a lower GCC version than 5.0, the workaround proposed by the following link
+   should be used: `<https://github.com/intel/intel-ipsec-mb/issues/40>`_.
+
+
 As a reference, the following table shows a mapping between the past DPDK versions
 and the external crypto libraries supported by them:
 
diff --git a/doc/guides/cryptodevs/aesni_mb.rst b/doc/guides/cryptodevs/aesni_mb.rst
index 5d8fb46..465d20d 100644
--- a/doc/guides/cryptodevs/aesni_mb.rst
+++ b/doc/guides/cryptodevs/aesni_mb.rst
@@ -72,6 +72,12 @@  can be downloaded from `<https://github.com/01org/intel-ipsec-mb/archive/v0.53.z
     make
     make install
 
+.. note::
+
+   Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.
+   If a lower GCC version than 5.0, the workaround proposed by the following link
+   should be used: `<https://github.com/intel/intel-ipsec-mb/issues/40>`_.
+
 As a reference, the following table shows a mapping between the past DPDK versions
 and the Multi-Buffer library version supported by them:
 
diff --git a/doc/guides/cryptodevs/kasumi.rst b/doc/guides/cryptodevs/kasumi.rst
index 6c86fe2..0d48d10 100644
--- a/doc/guides/cryptodevs/kasumi.rst
+++ b/doc/guides/cryptodevs/kasumi.rst
@@ -47,6 +47,12 @@  on their system before building DPDK:
     make
     make install
 
+.. note::
+
+   Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.
+   If a lower GCC version than 5.0, the workaround proposed by the following link
+   should be used: `<https://github.com/intel/intel-ipsec-mb/issues/40>`_.
+
 As a reference, the following table shows a mapping between the past DPDK versions
 and the external crypto libraries supported by them:
 
diff --git a/doc/guides/cryptodevs/snow3g.rst b/doc/guides/cryptodevs/snow3g.rst
index 8fb06f4..5045c06 100644
--- a/doc/guides/cryptodevs/snow3g.rst
+++ b/doc/guides/cryptodevs/snow3g.rst
@@ -46,6 +46,12 @@  on their system before building DPDK:
     make
     make install
 
+.. note::
+
+   Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.
+   If a lower GCC version than 5.0, the workaround proposed by the following link
+   should be used: `<https://github.com/intel/intel-ipsec-mb/issues/40>`_.
+
 As a reference, the following table shows a mapping between the past DPDK versions
 and the external crypto libraries supported by them:
 
diff --git a/doc/guides/cryptodevs/zuc.rst b/doc/guides/cryptodevs/zuc.rst
index 23d618d..38ea999 100644
--- a/doc/guides/cryptodevs/zuc.rst
+++ b/doc/guides/cryptodevs/zuc.rst
@@ -46,6 +46,12 @@  on their system before building DPDK:
     make
     make install
 
+.. note::
+
+   Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.
+   If a lower GCC version than 5.0, the workaround proposed by the following link
+   should be used: `<https://github.com/intel/intel-ipsec-mb/issues/40>`_.
+
 As a reference, the following table shows a mapping between the past DPDK versions
 and the external crypto libraries supported by them: