diff mbox

[dpdk-dev,1/1] doc: update doc and release notes for szedata2 driver

Message ID 1524819425-5286-1-git-send-email-vido@cesnet.cz (mailing list archive)
State Accepted, archived
Delegated to: Ferruh Yigit
Headers show

Checks

Context Check Description
ci/checkpatch success coding style OK
ci/Intel-compilation success Compilation OK

Commit Message

Matej Vido April 27, 2018, 8:57 a.m. UTC
New version of the packages with dependencies for the szedata2
driver is needed due to the new API of the libsze2 library which
is used in the driver.
The documentation and the release notes are updated to contain
the information about the required versions.

Signed-off-by: Matej Vido <vido@cesnet.cz>
Acked-by: Jan Remes <remes@netcope.com>
---
 doc/guides/nics/szedata2.rst           | 9 +++++++++
 doc/guides/rel_notes/release_18_05.rst | 4 ++++
 2 files changed, 13 insertions(+)

Comments

Ferruh Yigit April 27, 2018, 1:11 p.m. UTC | #1
On 4/27/2018 9:57 AM, Matej Vido wrote:
> New version of the packages with dependencies for the szedata2
> driver is needed due to the new API of the libsze2 library which
> is used in the driver.
> The documentation and the release notes are updated to contain
> the information about the required versions.
> 
> Signed-off-by: Matej Vido <vido@cesnet.cz>
> Acked-by: Jan Remes <remes@netcope.com>

Applied to dpdk-next-net/master, thanks.

(Thanks for the update)

> @@ -54,6 +54,15 @@ separately:
>  Information about getting the dependencies can be found `here
>  <http://www.netcope.com/en/company/community-support/dpdk-libsze2>`_.
>  
> +Versions of the packages
> +~~~~~~~~~~~~~~~~~~~~~~~

Giving warning because of missing char [1], fixed while applying.

[1]
dpdk/doc/guides/nics/szedata2.rst:58: WARNING: Title underline too short.

Versions of the packages
~~~~~~~~~~~~~~~~~~~~~~~
diff mbox

Patch

diff --git a/doc/guides/nics/szedata2.rst b/doc/guides/nics/szedata2.rst
index 96fed30..a34fffc 100644
--- a/doc/guides/nics/szedata2.rst
+++ b/doc/guides/nics/szedata2.rst
@@ -54,6 +54,15 @@  separately:
 Information about getting the dependencies can be found `here
 <http://www.netcope.com/en/company/community-support/dpdk-libsze2>`_.
 
+Versions of the packages
+~~~~~~~~~~~~~~~~~~~~~~~
+
+The minimum version of the provided packages:
+
+* for DPDK from 18.05: **4.4.1**
+
+* for DPDK up to 18.02 (including): **3.0.5**
+
 Configuration
 -------------
 
diff --git a/doc/guides/rel_notes/release_18_05.rst b/doc/guides/rel_notes/release_18_05.rst
index 3d18298..cce82ba 100644
--- a/doc/guides/rel_notes/release_18_05.rst
+++ b/doc/guides/rel_notes/release_18_05.rst
@@ -81,6 +81,10 @@  New Features
 * **Updated szedata2 PMD.**
 
   Added support for new NFB-200G2QL card.
+  New API was introduced in the libsze2 library which the szedata2 PMD depends
+  on thus the new version of the library was needed.
+  New versions of the packages are available and the minimum required version
+  is 4.4.1.
 
 * **Added support for Broadcom NetXtreme-S (BCM58800) family of controllers (aka Stingray)**