diff mbox

[dpdk-dev,v2] doc: Add requirements for x32 ABI

Message ID 1424104034-6940-1-git-send-email-danielx.t.mrzyglod@intel.com (mailing list archive)
State Accepted, archived
Headers show

Commit Message

Daniel Mrzyglod Feb. 16, 2015, 4:27 p.m. UTC
This patch add requirements about compiler and distribution support.

v2:
spelling fixes

Signed-off-by: Daniel Mrzyglod <danielx.t.mrzyglod@intel.com>
---
 doc/guides/linux_gsg/sys_reqs.rst | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)

Comments

De Lara Guarch, Pablo Feb. 16, 2015, 4:29 p.m. UTC | #1
> -----Original Message-----
> From: dev [mailto:dev-bounces@dpdk.org] On Behalf Of Daniel Mrzyglod
> Sent: Monday, February 16, 2015 4:27 PM
> To: dev@dpdk.org
> Subject: [dpdk-dev] [PATCH v2] doc: Add requirements for x32 ABI
> 
> This patch add requirements about compiler and distribution support.
> 
> v2:
> spelling fixes
> 
> Signed-off-by: Daniel Mrzyglod <danielx.t.mrzyglod@intel.com>
> ---
>  doc/guides/linux_gsg/sys_reqs.rst | 11 +++++++++--
>  1 file changed, 9 insertions(+), 2 deletions(-)
> 
> diff --git a/doc/guides/linux_gsg/sys_reqs.rst
> b/doc/guides/linux_gsg/sys_reqs.rst
> index 8e2307b..ef4196e 100644
> --- a/doc/guides/linux_gsg/sys_reqs.rst
> +++ b/doc/guides/linux_gsg/sys_reqs.rst
> @@ -62,7 +62,7 @@ Compilation of the DPDK
>  *   coreutils:  cmp, sed, grep, arch
> 
>  *   gcc: versions 4.5.x or later is recommended for i686/x86_64. versions 4.8.x
> or later is recommanded
> -    for ppc_64. On some distributions, some specific compiler flags and linker
> flags are enabled by
> +    for ppc_64 and x86_x32 ABI. On some distributions, some specific
> compiler flags and linker flags are enabled by
>      default and affect performance (- fstack-protector, for example). Please
> refer to the documentation
>      of your distribution and to gcc -dumpspecs.
> 
> @@ -78,7 +78,14 @@ Compilation of the DPDK
> 
>      glibc.ppc64, libgcc.ppc64, libstdc++.ppc64 and glibc-devel.ppc64 for IBM
> ppc_64;
> 
> -*   Python, version 2.6 or 2.7, to use various helper scripts included in the
> DPDK package
> +.. note::
> +
> +    x86_x32 ABI is currently supported with distribution packages only on
> Ubuntu
> +    higher than 13.10 or recent debian distribution. The only supported
> compiler is gcc 4.8+.
> +
> +.. note::
> +
> +    Python, version 2.6 or 2.7, to use various helper scripts included in the
> DPDK package
> 
> 
>  **Optional Tools:**
> --
> 2.1.0

Acked-by: Pablo de Lara <pablo.de.lara.guarch@intel.com>

Thanks Daniel!
Thomas Monjalon Feb. 18, 2015, 7:33 p.m. UTC | #2
> > This patch add requirements about compiler and distribution support.
> > 
> > v2:
> > spelling fixes
> > 
> > Signed-off-by: Daniel Mrzyglod <danielx.t.mrzyglod@intel.com>
> 
> Acked-by: Pablo de Lara <pablo.de.lara.guarch@intel.com>
> 
> Thanks Daniel!

Applied, thanks
diff mbox

Patch

diff --git a/doc/guides/linux_gsg/sys_reqs.rst b/doc/guides/linux_gsg/sys_reqs.rst
index 8e2307b..ef4196e 100644
--- a/doc/guides/linux_gsg/sys_reqs.rst
+++ b/doc/guides/linux_gsg/sys_reqs.rst
@@ -62,7 +62,7 @@  Compilation of the DPDK
 *   coreutils:  cmp, sed, grep, arch
 
 *   gcc: versions 4.5.x or later is recommended for i686/x86_64. versions 4.8.x or later is recommanded
-    for ppc_64. On some distributions, some specific compiler flags and linker flags are enabled by
+    for ppc_64 and x86_x32 ABI. On some distributions, some specific compiler flags and linker flags are enabled by
     default and affect performance (- fstack-protector, for example). Please refer to the documentation
     of your distribution and to gcc -dumpspecs.
 
@@ -78,7 +78,14 @@  Compilation of the DPDK
 
     glibc.ppc64, libgcc.ppc64, libstdc++.ppc64 and glibc-devel.ppc64 for IBM ppc_64;
 
-*   Python, version 2.6 or 2.7, to use various helper scripts included in the DPDK package
+.. note::
+
+    x86_x32 ABI is currently supported with distribution packages only on Ubuntu
+    higher than 13.10 or recent debian distribution. The only supported  compiler is gcc 4.8+.
+
+.. note::
+
+    Python, version 2.6 or 2.7, to use various helper scripts included in the DPDK package
 
 
 **Optional Tools:**