[v5,01/11] ethdev: add extensions attributes to IPv6 item
diff mbox series

Message ID 97bc93abb2093db8eebba0fbe1b9692afb1e7095.1602494556.git.dekelp@nvidia.com
State Superseded, archived
Delegated to: Ferruh Yigit
Headers show
Series
  • support match on L3 fragmented packets
Related show

Checks

Context Check Description
ci/checkpatch success coding style OK

Commit Message

Dekel Peled Oct. 12, 2020, 10:43 a.m. UTC
Using the current implementation of DPDK, an application cannot match on
IPv6 packets, based on the existing extension headers, in a simple way.

Field 'Next Header' in IPv6 header indicates type of the first extension
header only. Following extension headers can't be identified by
inspecting the IPv6 header.
As a result, the existence or absence of specific extension headers
can't be used for packet matching.

For example, fragmented IPv6 packets contain a dedicated extension header
(which is implemented in a later patch of this series).
Non-fragmented packets don't contain the fragment extension header.
For an application to match on non-fragmented IPv6 packets, the current
implementation doesn't provide a suitable solution.
Matching on the Next Header field is not sufficient, since additional
extension headers might be present in the same packet.
To match on fragmented IPv6 packets, the same difficulty exists.

This patch implements the update as detailed in RFC [1].
A set of additional values will be added to IPv6 header struct.
These values will indicate the existence of every defined extension
header type, providing simple means for identification of existing
extensions in the packet header.
Continuing the above example, fragmented packets can be identified using
the specific value indicating existence of fragment extension header.
To match on non-fragmented IPv6 packets, need to use frag_ext_exist 0.
To match on fragmented IPv6 packets, need to use frag_ext_exist 1.
To match on any IPv6 packets, the frag_ext_exist field should
not be specified for match.

[1] https://mails.dpdk.org/archives/dev/2020-August/177257.html

Signed-off-by: Dekel Peled <dekelp@nvidia.com>
Acked-by: Ori Kam <orika@nvidia.com>
---
 doc/guides/prog_guide/rte_flow.rst | 22 +++++++++++++++++++---
 lib/librte_ethdev/rte_flow.h       | 25 +++++++++++++++++++++++--
 2 files changed, 42 insertions(+), 5 deletions(-)

Comments

Thomas Monjalon Oct. 12, 2020, 8:41 p.m. UTC | #1
12/10/2020 12:43, Dekel Peled:
> - * Note: IPv6 options are handled by dedicated pattern items, see
> - * RTE_FLOW_ITEM_TYPE_IPV6_EXT.
> + * Dedicated flags indicate existence of specific extension headers.
> + * Every type of extension header can use a dedicated pattern item, or
> + * the generic item RTE_FLOW_ITEM_TYPE_IPV6_EXT.

I don't understand this last sentence.

>   */
>  struct rte_flow_item_ipv6 {
>  	struct rte_ipv6_hdr hdr; /**< IPv6 header definition. */
> +	uint32_t hop_ext_exist:1;
> +	/**< Hop-by-Hop Options extension header exists. */
> +	uint32_t rout_ext_exist:1;

"rout" looks weird. Would be "route" appropriate?

> +	/**< Routing extension header exists. */
> +	uint32_t frag_ext_exist:1;
> +	/**< Fragment extension header exists. */
> +	uint32_t auth_ext_exist:1;
> +	/**< Authentication extension header exists. */
> +	uint32_t esp_ext_exist:1;
> +	/**< Encapsulation Security Payload extension header exists. */
> +	uint32_t dest_ext_exist:1;
> +	/**< Destination Options extension header exists. */
> +	uint32_t mobil_ext_exist:1;
> +	/**< Mobility extension header exists. */
> +	uint32_t hip_ext_exist:1;
> +	/**< Host Identity Protocol extension header exists. */
> +	uint32_t shim6_ext_exist:1;
> +	/**< Shim6 Protocol extension header exists. */

About the field names, the "_exist" suffix is pretty clear,
but without being able to say why, I feel it is a strange name.
I was thinking about renaming the fields with a "has_" prefix.
Does it look better?
Dekel Peled Oct. 13, 2020, 8:22 a.m. UTC | #2
Thanks, PSB.

> -----Original Message-----
> From: Thomas Monjalon <thomas@monjalon.net>
> Sent: Monday, October 12, 2020 11:42 PM
> To: Ori Kam <orika@nvidia.com>; Dekel Peled <dekelp@nvidia.com>
> Cc: ferruh.yigit@intel.com; arybchenko@solarflare.com;
> konstantin.ananyev@intel.com; olivier.matz@6wind.com;
> wenzhuo.lu@intel.com; beilei.xing@intel.com;
> bernard.iremonger@intel.com; Matan Azrad <matan@nvidia.com>; Shahaf
> Shuler <shahafs@nvidia.com>; Slava Ovsiienko <viacheslavo@nvidia.com>;
> dev@dpdk.org; Asaf Penso <asafp@nvidia.com>
> Subject: Re: [dpdk-dev] [PATCH v5 01/11] ethdev: add extensions attributes
> to IPv6 item
> 
> 12/10/2020 12:43, Dekel Peled:
> > - * Note: IPv6 options are handled by dedicated pattern items, see
> > - * RTE_FLOW_ITEM_TYPE_IPV6_EXT.
> > + * Dedicated flags indicate existence of specific extension headers.
> > + * Every type of extension header can use a dedicated pattern item,
> > + or
> > + * the generic item RTE_FLOW_ITEM_TYPE_IPV6_EXT.
> 
> I don't understand this last sentence.

I'll rephrase.

> 
> >   */
> >  struct rte_flow_item_ipv6 {
> >  	struct rte_ipv6_hdr hdr; /**< IPv6 header definition. */
> > +	uint32_t hop_ext_exist:1;
> > +	/**< Hop-by-Hop Options extension header exists. */
> > +	uint32_t rout_ext_exist:1;
> 
> "rout" looks weird. Would be "route" appropriate?

I'll change to "route".

> 
> > +	/**< Routing extension header exists. */
> > +	uint32_t frag_ext_exist:1;
> > +	/**< Fragment extension header exists. */
> > +	uint32_t auth_ext_exist:1;
> > +	/**< Authentication extension header exists. */
> > +	uint32_t esp_ext_exist:1;
> > +	/**< Encapsulation Security Payload extension header exists. */
> > +	uint32_t dest_ext_exist:1;
> > +	/**< Destination Options extension header exists. */
> > +	uint32_t mobil_ext_exist:1;
> > +	/**< Mobility extension header exists. */
> > +	uint32_t hip_ext_exist:1;
> > +	/**< Host Identity Protocol extension header exists. */
> > +	uint32_t shim6_ext_exist:1;
> > +	/**< Shim6 Protocol extension header exists. */
> 
> About the field names, the "_exist" suffix is pretty clear, but without being
> able to say why, I feel it is a strange name.
> I was thinking about renaming the fields with a "has_" prefix.
> Does it look better?

I'm afraid a "has_" prefix doesn't look appropriate IMHO.
I still prefer the "_exist" suffix.

>

Patch
diff mbox series

diff --git a/doc/guides/prog_guide/rte_flow.rst b/doc/guides/prog_guide/rte_flow.rst
index 119b128..ae090db 100644
--- a/doc/guides/prog_guide/rte_flow.rst
+++ b/doc/guides/prog_guide/rte_flow.rst
@@ -946,11 +946,27 @@  Item: ``IPV6``
 
 Matches an IPv6 header.
 
-Note: IPv6 options are handled by dedicated pattern items, see `Item:
-IPV6_EXT`_.
+Dedicated flags indicate existence of specific extension headers.
+Every type of extension header can use a dedicated pattern item, or
+the generic `Item: IPV6_EXT`_.
+To match on packets containing a specific extension header, an application
+should match on the dedicated flag set to 1.
+To match on packets not containing a specific extension header, an application
+should match on the dedicated flag clear to 0.
+In case application doesn't care about the existence of a specific extension
+header, it should not specify the dedicated flag for matching.
 
 - ``hdr``: IPv6 header definition (``rte_ip.h``).
-- Default ``mask`` matches source and destination addresses only.
+- ``hop_ext_exist``: Hop-by-Hop Options extension header exists.
+- ``rout_ext_exist``: Routing extension header exists.
+- ``frag_ext_exist``: Fragment extension header exists.
+- ``auth_ext_exist``: Authentication extension header exists.
+- ``esp_ext_exist``: Encapsulation Security Payload extension header exists.
+- ``dest_ext_exist``: Destination Options extension header exists.
+- ``mobil_ext_exist``: Mobility extension header exists.
+- ``hip_ext_exist``: Host Identity Protocol extension header exists.
+- ``shim6_ext_exist``: Shim6 Protocol extension header exists.
+- Default ``mask`` matches ``hdr`` source and destination addresses only.
 
 Item: ``ICMP``
 ^^^^^^^^^^^^^^
diff --git a/lib/librte_ethdev/rte_flow.h b/lib/librte_ethdev/rte_flow.h
index da8bfa5..5b5bed2 100644
--- a/lib/librte_ethdev/rte_flow.h
+++ b/lib/librte_ethdev/rte_flow.h
@@ -792,11 +792,32 @@  struct rte_flow_item_ipv4 {
  *
  * Matches an IPv6 header.
  *
- * Note: IPv6 options are handled by dedicated pattern items, see
- * RTE_FLOW_ITEM_TYPE_IPV6_EXT.
+ * Dedicated flags indicate existence of specific extension headers.
+ * Every type of extension header can use a dedicated pattern item, or
+ * the generic item RTE_FLOW_ITEM_TYPE_IPV6_EXT.
  */
 struct rte_flow_item_ipv6 {
 	struct rte_ipv6_hdr hdr; /**< IPv6 header definition. */
+	uint32_t hop_ext_exist:1;
+	/**< Hop-by-Hop Options extension header exists. */
+	uint32_t rout_ext_exist:1;
+	/**< Routing extension header exists. */
+	uint32_t frag_ext_exist:1;
+	/**< Fragment extension header exists. */
+	uint32_t auth_ext_exist:1;
+	/**< Authentication extension header exists. */
+	uint32_t esp_ext_exist:1;
+	/**< Encapsulation Security Payload extension header exists. */
+	uint32_t dest_ext_exist:1;
+	/**< Destination Options extension header exists. */
+	uint32_t mobil_ext_exist:1;
+	/**< Mobility extension header exists. */
+	uint32_t hip_ext_exist:1;
+	/**< Host Identity Protocol extension header exists. */
+	uint32_t shim6_ext_exist:1;
+	/**< Shim6 Protocol extension header exists. */
+	uint32_t reserved:23;
+	/**< Reserved for future extension headers, must be zero. */
 };
 
 /** Default mask for RTE_FLOW_ITEM_TYPE_IPV6. */