[v4,3/4] doc/linux_gsg: require pyelftools for pmdinfogen
diff mbox series

Message ID 20200708212335.25338-4-dmitry.kozliuk@gmail.com
State Superseded
Delegated to: David Marchand
Headers show
Series
  • pmdinfogen: rewrite in Python
Related show

Checks

Context Check Description
ci/Intel-compilation success Compilation OK
ci/checkpatch success coding style OK

Commit Message

Dmitry Kozlyuk July 8, 2020, 9:23 p.m. UTC
The package is available on all major distributions.
FreeBSD has no system requirements section in its GSG,
Windows currently neither uses pmdinfogen not is supported by it.

Signed-off-by: Dmitry Kozlyuk <dmitry.kozliuk@gmail.com>
---
 doc/guides/linux_gsg/sys_reqs.rst | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Bruce Richardson July 21, 2020, 1:39 p.m. UTC | #1
On Thu, Jul 09, 2020 at 12:23:34AM +0300, Dmitry Kozlyuk wrote:
> The package is available on all major distributions.
> FreeBSD has no system requirements section in its GSG,
> Windows currently neither uses pmdinfogen not is supported by it.
> 
> Signed-off-by: Dmitry Kozlyuk <dmitry.kozliuk@gmail.com>
> ---
>  doc/guides/linux_gsg/sys_reqs.rst | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/doc/guides/linux_gsg/sys_reqs.rst b/doc/guides/linux_gsg/sys_reqs.rst
> index a124656bc..ef2037ca7 100644
> --- a/doc/guides/linux_gsg/sys_reqs.rst
> +++ b/doc/guides/linux_gsg/sys_reqs.rst
> @@ -56,6 +56,12 @@ Compilation of the DPDK
>      * If the packaged version is below the minimum version, the latest versions
>        can be installed from Python's "pip" repository: ``pip3 install meson ninja``
>  
> +*   ``pyelftools`` (version 0.22+)
> +
> +    * For RHEL/Fedora systems it can be installed using ``dnf install python-pyelftools``
> +
> +    * For Ubuntu/Debian it can be installed using ``apt install python3-pyelftools``
> +

If you want for completeness you can add:
 * For FreeBSD it can be installed using ``pkg install py37-pyelftools``, 
   where py37 refers to the python version in use.

>  *   Library for handling NUMA (Non Uniform Memory Access).
>  
>      * ``numactl-devel`` in RHEL/Fedora;
> -- 
> 2.25.4
>
Bruce Richardson July 21, 2020, 2:04 p.m. UTC | #2
On Thu, Jul 09, 2020 at 12:23:34AM +0300, Dmitry Kozlyuk wrote:
> The package is available on all major distributions.
> FreeBSD has no system requirements section in its GSG,
> Windows currently neither uses pmdinfogen not is supported by it.
> 
> Signed-off-by: Dmitry Kozlyuk <dmitry.kozliuk@gmail.com>
> ---
>  doc/guides/linux_gsg/sys_reqs.rst | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/doc/guides/linux_gsg/sys_reqs.rst b/doc/guides/linux_gsg/sys_reqs.rst
> index a124656bc..ef2037ca7 100644
> --- a/doc/guides/linux_gsg/sys_reqs.rst
> +++ b/doc/guides/linux_gsg/sys_reqs.rst
> @@ -56,6 +56,12 @@ Compilation of the DPDK
>      * If the packaged version is below the minimum version, the latest versions
>        can be installed from Python's "pip" repository: ``pip3 install meson ninja``
>  
> +*   ``pyelftools`` (version 0.22+)
> +
> +    * For RHEL/Fedora systems it can be installed using ``dnf install python-pyelftools``
> +
> +    * For Ubuntu/Debian it can be installed using ``apt install python3-pyelftools``
> +
>  *   Library for handling NUMA (Non Uniform Memory Access).
>  
>      * ``numactl-devel`` in RHEL/Fedora;
> -- 
This can be merged into patch 2, I think.
Bruce Richardson July 21, 2020, 2:05 p.m. UTC | #3
On Tue, Jul 21, 2020 at 02:39:35PM +0100, Bruce Richardson wrote:
> On Thu, Jul 09, 2020 at 12:23:34AM +0300, Dmitry Kozlyuk wrote:
> > The package is available on all major distributions.
> > FreeBSD has no system requirements section in its GSG,
> > Windows currently neither uses pmdinfogen not is supported by it.
> > 
> > Signed-off-by: Dmitry Kozlyuk <dmitry.kozliuk@gmail.com>
> > ---
> >  doc/guides/linux_gsg/sys_reqs.rst | 6 ++++++
> >  1 file changed, 6 insertions(+)
> > 
> > diff --git a/doc/guides/linux_gsg/sys_reqs.rst b/doc/guides/linux_gsg/sys_reqs.rst
> > index a124656bc..ef2037ca7 100644
> > --- a/doc/guides/linux_gsg/sys_reqs.rst
> > +++ b/doc/guides/linux_gsg/sys_reqs.rst
> > @@ -56,6 +56,12 @@ Compilation of the DPDK
> >      * If the packaged version is below the minimum version, the latest versions
> >        can be installed from Python's "pip" repository: ``pip3 install meson ninja``
> >  
> > +*   ``pyelftools`` (version 0.22+)
> > +
> > +    * For RHEL/Fedora systems it can be installed using ``dnf install python-pyelftools``
> > +
> > +    * For Ubuntu/Debian it can be installed using ``apt install python3-pyelftools``
> > +
> 
> If you want for completeness you can add:
>  * For FreeBSD it can be installed using ``pkg install py37-pyelftools``, 
>    where py37 refers to the python version in use.
> 

Sorry, missed the fact that this was the Linux GSG. Never mind...

Patch
diff mbox series

diff --git a/doc/guides/linux_gsg/sys_reqs.rst b/doc/guides/linux_gsg/sys_reqs.rst
index a124656bc..ef2037ca7 100644
--- a/doc/guides/linux_gsg/sys_reqs.rst
+++ b/doc/guides/linux_gsg/sys_reqs.rst
@@ -56,6 +56,12 @@  Compilation of the DPDK
     * If the packaged version is below the minimum version, the latest versions
       can be installed from Python's "pip" repository: ``pip3 install meson ninja``
 
+*   ``pyelftools`` (version 0.22+)
+
+    * For RHEL/Fedora systems it can be installed using ``dnf install python-pyelftools``
+
+    * For Ubuntu/Debian it can be installed using ``apt install python3-pyelftools``
+
 *   Library for handling NUMA (Non Uniform Memory Access).
 
     * ``numactl-devel`` in RHEL/Fedora;