build: remove non-x86 file from non-x86 net/avf builds

Message ID 20180926101751.18591-1-bluca@debian.org (mailing list archive)
State Not Applicable, archived
Headers
Series build: remove non-x86 file from non-x86 net/avf builds |

Checks

Context Check Description
ci/checkpatch success coding style OK
ci/Intel-compilation success Compilation OK

Commit Message

Luca Boccassi Sept. 26, 2018, 10:17 a.m. UTC
  The sse file was added both conditionally on building for x86 and
unconditionally, which breaks the build on non-x86.

Fixes: bd29fd07ba64 ("build: add Meson files for avf PMD")

Signed-off-by: Luca Boccassi <bluca@debian.org>
---
 drivers/net/avf/meson.build | 1 -
 1 file changed, 1 deletion(-)
  

Comments

Ferruh Yigit Sept. 26, 2018, 10:48 a.m. UTC | #1
On 9/26/2018 11:17 AM, Luca Boccassi wrote:
> The sse file was added both conditionally on building for x86 and
> unconditionally, which breaks the build on non-x86.
> 
> Fixes: bd29fd07ba64 ("build: add Meson files for avf PMD")
> 
> Signed-off-by: Luca Boccassi <bluca@debian.org>
> ---
>  drivers/net/avf/meson.build | 1 -
>  1 file changed, 1 deletion(-)
> 
> diff --git a/drivers/net/avf/meson.build b/drivers/net/avf/meson.build
> index b5ad9cc673..9a05ebbf4e 100644
> --- a/drivers/net/avf/meson.build
> +++ b/drivers/net/avf/meson.build
> @@ -9,7 +9,6 @@ objs = [base_objs]
>  sources = files(
>  	'avf_ethdev.c',
>  	'avf_rxtx.c',
> -	'avf_rxtx_vec_sse.c',

The patch merged [1] already don't have this.

[1]
https://patches.dpdk.org/patch/44908/
  
Luca Boccassi Sept. 26, 2018, 10:56 a.m. UTC | #2
On Wed, 2018-09-26 at 11:48 +0100, Ferruh Yigit wrote:
> On 9/26/2018 11:17 AM, Luca Boccassi wrote:
> > The sse file was added both conditionally on building for x86 and
> > unconditionally, which breaks the build on non-x86.
> > 
> > Fixes: bd29fd07ba64 ("build: add Meson files for avf PMD")
> > 
> > Signed-off-by: Luca Boccassi <bluca@debian.org>
> > ---
> >  drivers/net/avf/meson.build | 1 -
> >  1 file changed, 1 deletion(-)
> > 
> > diff --git a/drivers/net/avf/meson.build
> > b/drivers/net/avf/meson.build
> > index b5ad9cc673..9a05ebbf4e 100644
> > --- a/drivers/net/avf/meson.build
> > +++ b/drivers/net/avf/meson.build
> > @@ -9,7 +9,6 @@ objs = [base_objs]
> >  sources = files(
> >  	'avf_ethdev.c',
> >  	'avf_rxtx.c',
> > -	'avf_rxtx_vec_sse.c',
> 
> The patch merged [1] already don't have this.
> 
> [1]
> https://patches.dpdk.org/patch/44908/

Lol, I used an old git branch to check Bruce's patch, thanks, changed
status on patchwork
  

Patch

diff --git a/drivers/net/avf/meson.build b/drivers/net/avf/meson.build
index b5ad9cc673..9a05ebbf4e 100644
--- a/drivers/net/avf/meson.build
+++ b/drivers/net/avf/meson.build
@@ -9,7 +9,6 @@  objs = [base_objs]
 sources = files(
 	'avf_ethdev.c',
 	'avf_rxtx.c',
-	'avf_rxtx_vec_sse.c',
 	'avf_vchnl.c',
 )