[11/15] net/sfc: rename version map after library file name

Message ID 20180910200415.8340-12-bluca@debian.org (mailing list archive)
State Superseded, archived
Headers
Series rename PMDs map files to match library name and add Meson files |

Checks

Context Check Description
ci/checkpatch success coding style OK
ci/Intel-compilation success Compilation OK

Commit Message

Luca Boccassi Sept. 10, 2018, 8:04 p.m. UTC
  The library is called librte_pmd_sfc_efx, so rename the map file
and set the name in the meson file so that the built library names with
meson and legacy makefiles are the same

Fixes: bfa8d5990cd6 ("net/sfc: support meson build")
Cc: stable@dpdk.org

Signed-off-by: Luca Boccassi <bluca@debian.org>
---
 drivers/net/sfc/Makefile                                        | 2 +-
 drivers/net/sfc/meson.build                                     | 2 ++
 .../{rte_pmd_sfc_version.map => rte_pmd_sfc_efx_version.map}    | 0
 3 files changed, 3 insertions(+), 1 deletion(-)
 rename drivers/net/sfc/{rte_pmd_sfc_version.map => rte_pmd_sfc_efx_version.map} (100%)
  

Patch

diff --git a/drivers/net/sfc/Makefile b/drivers/net/sfc/Makefile
index 3bb41a0001..2825649599 100644
--- a/drivers/net/sfc/Makefile
+++ b/drivers/net/sfc/Makefile
@@ -60,7 +60,7 @@  BASE_DRIVER_OBJS=$(sort $(patsubst %.c,%.o,$(notdir $(wildcard $(SRCDIR)/base/*.
 $(foreach obj, $(BASE_DRIVER_OBJS), \
   $(eval CFLAGS_$(obj)+=$(CFLAGS_BASE_DRIVER)))
 
-EXPORT_MAP := rte_pmd_sfc_version.map
+EXPORT_MAP := rte_pmd_sfc_efx_version.map
 
 LIBABIVER := 1
 
diff --git a/drivers/net/sfc/meson.build b/drivers/net/sfc/meson.build
index 2d34e869d8..d6572b82c0 100644
--- a/drivers/net/sfc/meson.build
+++ b/drivers/net/sfc/meson.build
@@ -6,6 +6,8 @@ 
 # This software was jointly developed between OKTET Labs (under contract
 # for Solarflare) and Solarflare Communications, Inc.
 
+name = 'sfc_efx'
+
 if arch_subdir != 'x86' or cc.sizeof('void *') == 4
 	build = false
 endif
diff --git a/drivers/net/sfc/rte_pmd_sfc_version.map b/drivers/net/sfc/rte_pmd_sfc_efx_version.map
similarity index 100%
rename from drivers/net/sfc/rte_pmd_sfc_version.map
rename to drivers/net/sfc/rte_pmd_sfc_efx_version.map