[10/15] net/thunderx: rename version map after library file name

Message ID 20180910200415.8340-11-bluca@debian.org (mailing list archive)
State Superseded, archived
Headers
Series rename PMDs map files to match library name and add Meson files |

Checks

Context Check Description
ci/checkpatch success coding style OK
ci/Intel-compilation success Compilation OK

Commit Message

Luca Boccassi Sept. 10, 2018, 8:04 p.m. UTC
  The library is called librte_pmd_thunderx_nicvf, so rename the map file
and set the name in the meson file so that the built library names with
meson and legacy makefiles are the same

Fixes: 7f615033d64f ("drivers/net: build Cavium NIC PMDs with meson")
Cc: stable@dpdk.org

Signed-off-by: Luca Boccassi <bluca@debian.org>
---
 drivers/net/thunderx/Makefile                                   | 2 +-
 drivers/net/thunderx/meson.build                                | 1 +
 ..._thunderx_version.map => rte_pmd_thunderx_nicvf_version.map} | 0
 3 files changed, 2 insertions(+), 1 deletion(-)
 rename drivers/net/thunderx/{rte_pmd_thunderx_version.map => rte_pmd_thunderx_nicvf_version.map} (100%)
  

Comments

Bruce Richardson Sept. 11, 2018, 1:09 p.m. UTC | #1
On Mon, Sep 10, 2018 at 09:04:10PM +0100, Luca Boccassi wrote:
> The library is called librte_pmd_thunderx_nicvf, so rename the map file
> and set the name in the meson file so that the built library names with
> meson and legacy makefiles are the same
> 
> Fixes: 7f615033d64f ("drivers/net: build Cavium NIC PMDs with meson")
> Cc: stable@dpdk.org
> 
> Signed-off-by: Luca Boccassi <bluca@debian.org>
> ---
Again, I'd prefer we use a symlink if we need to enforce backward
compatibility. I also think we should then use the deprecation procedure to
remove those symlinks in a later version.

/Bruce
  

Patch

diff --git a/drivers/net/thunderx/Makefile b/drivers/net/thunderx/Makefile
index e6bf497522..cc008bd3a4 100644
--- a/drivers/net/thunderx/Makefile
+++ b/drivers/net/thunderx/Makefile
@@ -16,7 +16,7 @@  LDLIBS += -lrte_eal -lrte_mbuf -lrte_mempool -lrte_ring
 LDLIBS += -lrte_ethdev -lrte_net -lrte_kvargs
 LDLIBS += -lrte_bus_pci
 
-EXPORT_MAP := rte_pmd_thunderx_version.map
+EXPORT_MAP := rte_pmd_thunderx_nicvf_version.map
 
 LIBABIVER := 1
 
diff --git a/drivers/net/thunderx/meson.build b/drivers/net/thunderx/meson.build
index 69819a97fa..0c1207455e 100644
--- a/drivers/net/thunderx/meson.build
+++ b/drivers/net/thunderx/meson.build
@@ -1,6 +1,7 @@ 
 # SPDX-License-Identifier: BSD-3-Clause
 # Copyright(c) 2017 Cavium, Inc
 
+name = 'thunderx_nicvf'
 subdir('base')
 objs = [base_objs]
 
diff --git a/drivers/net/thunderx/rte_pmd_thunderx_version.map b/drivers/net/thunderx/rte_pmd_thunderx_nicvf_version.map
similarity index 100%
rename from drivers/net/thunderx/rte_pmd_thunderx_version.map
rename to drivers/net/thunderx/rte_pmd_thunderx_nicvf_version.map