[v2] build: add PPC64 Meson build

Message ID 20180910113243.18881-1-bluca@debian.org (mailing list archive)
State Accepted, archived
Delegated to: Thomas Monjalon
Headers
Series [v2] build: add PPC64 Meson build |

Checks

Context Check Description
ci/checkpatch success coding style OK
ci/Intel-compilation success Compilation OK

Commit Message

Luca Boccassi Sept. 10, 2018, 11:32 a.m. UTC
  This has been only build-tested for now, on a native ppc64el POWER8E
machine running Debian sid.

Signed-off-by: Luca Boccassi <bluca@debian.org>
---
v2: fix indentation, drop march_opt in ppc build file

 config/meson.build                               | 10 +++++++++-
 config/ppc_64/meson.build                        | 11 +++++++++++
 lib/librte_eal/common/arch/ppc_64/meson.build    |  5 +++++
 .../common/include/arch/ppc_64/meson.build       | 16 ++++++++++++++++
 4 files changed, 41 insertions(+), 1 deletion(-)
 create mode 100644 config/ppc_64/meson.build
 create mode 100644 lib/librte_eal/common/arch/ppc_64/meson.build
 create mode 100644 lib/librte_eal/common/include/arch/ppc_64/meson.build
  

Comments

Bruce Richardson Sept. 10, 2018, 1:28 p.m. UTC | #1
On Mon, Sep 10, 2018 at 12:32:43PM +0100, Luca Boccassi wrote:
> This has been only build-tested for now, on a native ppc64el POWER8E
> machine running Debian sid.
> 
> Signed-off-by: Luca Boccassi <bluca@debian.org>
> ---
> v2: fix indentation, drop march_opt in ppc build file
> 
LGTM

Acked-by: Bruce Richardson <bruce.richardson@intel.com>
  
Thomas Monjalon Sept. 17, 2018, 10:22 a.m. UTC | #2
10/09/2018 15:28, Bruce Richardson:
> On Mon, Sep 10, 2018 at 12:32:43PM +0100, Luca Boccassi wrote:
> > This has been only build-tested for now, on a native ppc64el POWER8E
> > machine running Debian sid.
> > 
> > Signed-off-by: Luca Boccassi <bluca@debian.org>
> > ---
> > v2: fix indentation, drop march_opt in ppc build file
> > 
> LGTM
> 
> Acked-by: Bruce Richardson <bruce.richardson@intel.com>

Applied, thanks
  

Patch

diff --git a/config/meson.build b/config/meson.build
index 4d755323f4..6f9228c874 100644
--- a/config/meson.build
+++ b/config/meson.build
@@ -9,7 +9,13 @@  else
 endif
 dpdk_conf.set('RTE_MACHINE', machine)
 machine_args = []
-machine_args += '-march=' + machine
+# ppc64 does not support -march=native
+if host_machine.cpu_family().startswith('ppc') and machine == 'native'
+	machine_args += '-mcpu=' + machine
+	machine_args += '-mtune=' + machine
+else
+	machine_args += '-march=' + machine
+endif
 
 toolchain = cc.get_id()
 dpdk_conf.set_quoted('RTE_TOOLCHAIN', toolchain)
@@ -84,6 +90,8 @@  if host_machine.cpu_family().startswith('x86')
 	arch_subdir = 'x86'
 elif host_machine.cpu_family().startswith('arm') or host_machine.cpu_family().startswith('aarch')
 	arch_subdir = 'arm'
+elif host_machine.cpu_family().startswith('ppc')
+	arch_subdir = 'ppc_64'
 endif
 subdir(arch_subdir)
 dpdk_conf.set('RTE_COMPILE_TIME_CPUFLAGS', ','.join(compile_time_cpuflags))
diff --git a/config/ppc_64/meson.build b/config/ppc_64/meson.build
new file mode 100644
index 0000000000..e207c438bf
--- /dev/null
+++ b/config/ppc_64/meson.build
@@ -0,0 +1,11 @@ 
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Luca Boccassi <bluca@debian.org>
+
+dpdk_conf.set('RTE_ARCH', 'ppc_64')
+dpdk_conf.set('RTE_ARCH_PPC_64', 1)
+dpdk_conf.set('RTE_ARCH_64', 1)
+
+# overrides specific to ppc64
+dpdk_conf.set('RTE_MAX_LCORE', 256)
+dpdk_conf.set('RTE_MAX_NUMA_NODES', 32)
+dpdk_conf.set('RTE_CACHE_LINE_SIZE', 128)
diff --git a/lib/librte_eal/common/arch/ppc_64/meson.build b/lib/librte_eal/common/arch/ppc_64/meson.build
new file mode 100644
index 0000000000..40b3dc533a
--- /dev/null
+++ b/lib/librte_eal/common/arch/ppc_64/meson.build
@@ -0,0 +1,5 @@ 
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Luca Boccassi <bluca@debian.org>
+
+eal_common_arch_sources = files('rte_cpuflags.c',
+	'rte_cycles.c', 'rte_hypervisor.c')
diff --git a/lib/librte_eal/common/include/arch/ppc_64/meson.build b/lib/librte_eal/common/include/arch/ppc_64/meson.build
new file mode 100644
index 0000000000..00f9611768
--- /dev/null
+++ b/lib/librte_eal/common/include/arch/ppc_64/meson.build
@@ -0,0 +1,16 @@ 
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Luca Boccassi <bluca@debian.org>
+
+install_headers(
+	'rte_atomic.h',
+	'rte_byteorder.h',
+	'rte_cpuflags.h',
+	'rte_cycles.h',
+	'rte_io.h',
+	'rte_memcpy.h',
+	'rte_pause.h',
+	'rte_prefetch.h',
+	'rte_rwlock.h',
+	'rte_spinlock.h',
+	'rte_vect.h',
+	subdir: get_option('include_subdir_arch'))