[V3,1/3] framework: check the python version
diff mbox series

Message ID 20201023070959.32951-2-yufengx.mo@intel.com
State Superseded
Headers show
Series
  • [V3,1/3] framework: check the python version
Related show

Commit Message

Mo, YufengX Oct. 23, 2020, 7:09 a.m. UTC
implement a method to check the python version of tester and the server that run dts.
If the version is python2, print a warning message.

Signed-off-by: yufengmx <yufengx.mo@intel.com>
---
 framework/utils.py | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Ma, LihongX Oct. 23, 2020, 7:51 a.m. UTC | #1
> -----Original Message-----
> From: Mo, YufengX <yufengx.mo@intel.com>
> Sent: Friday, October 23, 2020 3:10 PM
> To: dts@dpdk.org; Tu, Lijuan <lijuan.tu@intel.com>; Ma, LihongX
> <lihongx.ma@intel.com>
> Cc: Mo, YufengX <yufengx.mo@intel.com>
> Subject: [dts][PATCH V3 1/3] framework: check the python version
> 
> 
> implement a method to check the python version of tester and the server
> that run dts.
> If the version is python2, print a warning message.
> 
> Signed-off-by: yufengmx <yufengx.mo@intel.com>
> ---
>  framework/utils.py | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
> 
> diff --git a/framework/utils.py b/framework/utils.py index e74e6c5..9082e35
> +def check_dts_python_version():
> +    if sys.version_info.major < 3 or \
> +       sys.version_info.minor < 6 or \
> +       sys.version_info.micro < 9:
> +        print(RED(
> +            ("WARNING: Dts running node python version is lower than
> python 3.6, "
> +             "it is deprecated for use in DTS, "
> +             "and will not work in future releases.")), file=sys.stderr)
> +        print(RED("Please use Python >= 3.6.9 instead"),
> +file=sys.stderr)
> --
> 2.21.0

As the judgment condition is 'or', I think if my python3 version is 3.8.2, it will still print the warning information.
Can you check and optimize it ?


Regards,
Ma,lihong

Patch
diff mbox series

diff --git a/framework/utils.py b/framework/utils.py
index e74e6c5..9082e35 100644
--- a/framework/utils.py
+++ b/framework/utils.py
@@ -32,6 +32,7 @@ 
 import json         # json format
 import re
 import os
+import sys
 import inspect
 import socket
 import struct
@@ -280,3 +281,30 @@  def get_backtrace_object(file_name, obj_name):
         obj = getattr(frame.f_locals['self'], obj_name, None)
 
     return obj
+
+
+def check_crb_python_version(crb):
+    cmd = 'python3 -V'
+    out = crb.send_expect(cmd, '#', 5)
+    pat = "Python (\d+).(\d+).(\d+)"
+    result = re.findall(pat, out)
+    if not result or \
+       int(result[0][0]) < 3 or \
+       int(result[0][1]) < 6 or \
+       int(result[0][2]) < 9:
+        crb.logger.warning(
+            ("WARNING: Tester node python version is lower than python 3.6, "
+             "it is deprecated for use in DTS, "
+             "and will not work in future releases."))
+        crb.logger.warning("Please use Python >= 3.6.9 instead")
+
+
+def check_dts_python_version():
+    if sys.version_info.major < 3 or \
+       sys.version_info.minor < 6 or \
+       sys.version_info.micro < 9:
+        print(RED(
+            ("WARNING: Dts running node python version is lower than python 3.6, "
+             "it is deprecated for use in DTS, "
+             "and will not work in future releases.")), file=sys.stderr)
+        print(RED("Please use Python >= 3.6.9 instead"), file=sys.stderr)