[v5,12/20] doc: remove references to make from cryptodevs guides
diff mbox series

Message ID 20200921135931.13355-13-ciara.power@intel.com
State Superseded
Delegated to: Thomas Monjalon
Headers show
Series
  • remove make support in DPDK
Related show

Checks

Context Check Description
ci/checkpatch success coding style OK

Commit Message

Ciara Power Sept. 21, 2020, 1:59 p.m. UTC
Make is no longer supported for compiling DPDK, references are now
removed in the documentation.

Signed-off-by: Ciara Power <ciara.power@intel.com>
Reviewed-by: Kevin Laatz <kevin.laatz@intel.com>
---
 doc/guides/cryptodevs/aesni_gcm.rst |  4 +-
 doc/guides/cryptodevs/aesni_mb.rst  |  4 +-
 doc/guides/cryptodevs/armv8.rst     |  3 --
 doc/guides/cryptodevs/caam_jr.rst   | 30 -------------
 doc/guides/cryptodevs/ccp.rst       | 14 +++---
 doc/guides/cryptodevs/dpaa2_sec.rst | 25 -----------
 doc/guides/cryptodevs/dpaa_sec.rst  | 25 -----------
 doc/guides/cryptodevs/kasumi.rst    | 11 +----
 doc/guides/cryptodevs/mvsam.rst     | 10 +----
 doc/guides/cryptodevs/nitrox.rst    |  7 ---
 doc/guides/cryptodevs/null.rst      |  2 +-
 doc/guides/cryptodevs/octeontx.rst  | 12 +-----
 doc/guides/cryptodevs/octeontx2.rst |  8 +---
 doc/guides/cryptodevs/openssl.rst   |  6 +--
 doc/guides/cryptodevs/qat.rst       | 67 +++++++----------------------
 doc/guides/cryptodevs/scheduler.rst |  8 ----
 doc/guides/cryptodevs/snow3g.rst    | 10 +----
 doc/guides/cryptodevs/virtio.rst    | 20 +++------
 doc/guides/cryptodevs/zuc.rst       | 10 +----
 19 files changed, 40 insertions(+), 236 deletions(-)

Patch
diff mbox series

diff --git a/doc/guides/cryptodevs/aesni_gcm.rst b/doc/guides/cryptodevs/aesni_gcm.rst
index 74e0de63ad..013615e2d0 100644
--- a/doc/guides/cryptodevs/aesni_gcm.rst
+++ b/doc/guides/cryptodevs/aesni_gcm.rst
@@ -96,8 +96,6 @@  In order to enable this virtual crypto PMD, user must:
 
 * Build the multi buffer library (explained in Installation section).
 
-* Set CONFIG_RTE_LIBRTE_PMD_AESNI_GCM=y in config/common_base.
-
 To use the PMD in an application, user must:
 
 * Call rte_vdev_init("crypto_aesni_gcm") within the application.
@@ -117,5 +115,5 @@  Example:
 
 .. code-block:: console
 
-    ./l2fwd-crypto -l 1 -n 4 --vdev="crypto_aesni_gcm,socket_id=0,max_nb_sessions=128" \
+    ./dpdk-l2fwd-crypto -l 1 -n 4 --vdev="crypto_aesni_gcm,socket_id=0,max_nb_sessions=128" \
     -- -p 1 --cdev SW --chain AEAD --aead_algo "aes-gcm"
diff --git a/doc/guides/cryptodevs/aesni_mb.rst b/doc/guides/cryptodevs/aesni_mb.rst
index 15388d20ab..fd533ca65b 100644
--- a/doc/guides/cryptodevs/aesni_mb.rst
+++ b/doc/guides/cryptodevs/aesni_mb.rst
@@ -131,8 +131,6 @@  In order to enable this virtual crypto PMD, user must:
 
 * Build the multi buffer library (explained in Installation section).
 
-* Set CONFIG_RTE_LIBRTE_PMD_AESNI_MB=y in config/common_base.
-
 To use the PMD in an application, user must:
 
 * Call rte_vdev_init("crypto_aesni_mb") within the application.
@@ -152,7 +150,7 @@  Example:
 
 .. code-block:: console
 
-    ./l2fwd-crypto -l 1 -n 4 --vdev="crypto_aesni_mb,socket_id=0,max_nb_sessions=128" \
+    ./dpdk-l2fwd-crypto -l 1 -n 4 --vdev="crypto_aesni_mb,socket_id=0,max_nb_sessions=128" \
     -- -p 1 --cdev SW --chain CIPHER_HASH --cipher_algo "aes-cbc" --auth_algo "sha1-hmac"
 
 Extra notes
diff --git a/doc/guides/cryptodevs/armv8.rst b/doc/guides/cryptodevs/armv8.rst
index fee85354ba..d30ef6168e 100644
--- a/doc/guides/cryptodevs/armv8.rst
+++ b/doc/guides/cryptodevs/armv8.rst
@@ -40,9 +40,6 @@  In order to enable this virtual crypto PMD, user must:
 
 	make -C $ARMV8_CRYPTO_LIB_PATH/
 
-* Set CONFIG_RTE_LIBRTE_PMD_ARMV8_CRYPTO=y in
-  config/defconfig_arm64-armv8a-linux-gcc
-
 The corresponding device can be created only if the following features
 are supported by the CPU:
 
diff --git a/doc/guides/cryptodevs/caam_jr.rst b/doc/guides/cryptodevs/caam_jr.rst
index 6d9daf7364..5ef33ae78e 100644
--- a/doc/guides/cryptodevs/caam_jr.rst
+++ b/doc/guides/cryptodevs/caam_jr.rst
@@ -109,36 +109,6 @@  Currently supported by DPDK:
 
 * Follow the DPDK :ref:`Getting Started Guide for Linux <linux_gsg>` to setup the basic DPDK environment.
 
-Pre-Installation Configuration
-------------------------------
-
-Config File Options
-~~~~~~~~~~~~~~~~~~~
-
-The following options can be modified in the ``config`` file
-to enable caam_jr PMD.
-
-Please note that enabling debugging options may affect system performance.
-
-* ``CONFIG_RTE_LIBRTE_PMD_CAAM_JR`` (default ``n``)
-  By default it is only enabled in common_linux config.
-  Toggle compilation of the ``librte_pmd_caam_jr`` driver.
-
-* ``CONFIG_RTE_LIBRTE_PMD_CAAM_JR_BE`` (default ``n``)
-  By default it is disabled.
-  It can be used when the underlying hardware supports the CAAM in BE mode.
-  LS1043A, LS1046A and LS1012A support CAAM in BE mode.
-  LS1028A supports CAAM in LE mode.
-
-Installations
--------------
-To compile the caam_jr PMD for Linux arm64 gcc target, run the
-following ``make`` command:
-
-.. code-block:: console
-
-   cd <DPDK-source-directory>
-   make config T=arm64-armv8a-linux-gcc install
 
 Enabling logs
 -------------
diff --git a/doc/guides/cryptodevs/ccp.rst b/doc/guides/cryptodevs/ccp.rst
index a43fe92de9..9ca1979994 100644
--- a/doc/guides/cryptodevs/ccp.rst
+++ b/doc/guides/cryptodevs/ccp.rst
@@ -56,10 +56,8 @@  AEAD algorithms:
 Installation
 ------------
 
-To compile ccp PMD, it has to be enabled in the config/common_base file and openssl
-packages have to be installed in the build environment.
-
-* ``CONFIG_RTE_LIBRTE_PMD_CCP=y``
+To compile ccp PMD, openssl packages have to be installed in the build
+environment.
 
 For Ubuntu 16.04 LTS use below to install openssl in the build system:
 
@@ -77,7 +75,7 @@  e.g. for the 0x1456 device::
 
 	cd to the top-level DPDK directory
 	modprobe uio
-	insmod ./build/kmod/igb_uio.ko
+	insmod ./<build_dir>/kernel/linux/igb_uio/igb_uio.ko
 	echo "1022 1456" > /sys/bus/pci/drivers/igb_uio/new_id
 
 Another way to bind the CCP devices to DPDK UIO driver is by using the ``dpdk-devbind.py`` script.
@@ -86,8 +84,6 @@  The following command assumes ``BFD`` as ``0000:09:00.2``::
 	cd to the top-level DPDK directory
 	./usertools/dpdk-devbind.py -b igb_uio 0000:09:00.2
 
-In order to enable the ccp crypto PMD, user must set CONFIG_RTE_LIBRTE_PMD_CCP=y in config/common_base.
-
 To use the PMD in an application, user must:
 
 * Call rte_vdev_init("crypto_ccp") within the application.
@@ -109,7 +105,7 @@  To validate ccp pmd, l2fwd-crypto example can be used with following command:
 
 .. code-block:: console
 
-        sudo ./build/l2fwd-crypto -l 1 -n 4 --vdev "crypto_ccp" -- -p 0x1
+        sudo ./<build_dir>/examples/dpdk-l2fwd-crypto -l 1 -n 4 --vdev "crypto_ccp" -- -p 0x1
         --chain CIPHER_HASH --cipher_op ENCRYPT --cipher_algo aes-cbc
         --cipher_key 00:01:02:03:04:05:06:07:08:09:0a:0b:0c:0d:0e:0f
         --cipher_iv 00:01:02:03:04:05:06:07:08:09:0a:0b:0c:0d:0e:ff
@@ -124,7 +120,7 @@  following:
 
 .. code-block:: console
 
-        sudo ./build/l2fwd-crypto -l 1 -n 4 --vdev "crypto_ccp,ccp_auth_opt=1" -- -p 0x1
+        sudo ./<build_dir>/examples/dpdk-l2fwd-crypto -l 1 -n 4 --vdev "crypto_ccp,ccp_auth_opt=1" -- -p 0x1
         --chain CIPHER_HASH --cipher_op ENCRYPT --cipher_algo aes-cbc
         --cipher_key 00:01:02:03:04:05:06:07:08:09:0a:0b:0c:0d:0e:0f
         --cipher_iv 00:01:02:03:04:05:06:07:08:09:0a:0b:0c:0d:0e:ff
diff --git a/doc/guides/cryptodevs/dpaa2_sec.rst b/doc/guides/cryptodevs/dpaa2_sec.rst
index 3053636b82..080768a2e7 100644
--- a/doc/guides/cryptodevs/dpaa2_sec.rst
+++ b/doc/guides/cryptodevs/dpaa2_sec.rst
@@ -167,31 +167,6 @@  Currently supported by DPDK:
 
 - Follow the DPDK :ref:`Getting Started Guide for Linux <linux_gsg>` to setup the basic DPDK environment.
 
-Pre-Installation Configuration
-------------------------------
-
-Config File Options
-~~~~~~~~~~~~~~~~~~~
-
-Basic DPAA2 config file options are described in :ref:`dpaa2_overview`.
-In addition to those, the following options can be modified in the ``config`` file
-to enable DPAA2_SEC PMD.
-
-Please note that enabling debugging options may affect system performance.
-
-* ``CONFIG_RTE_LIBRTE_PMD_DPAA2_SEC`` (default ``n``)
-  By default it is only enabled in defconfig_arm64-dpaa-* config.
-  Toggle compilation of the ``librte_pmd_dpaa2_sec`` driver.
-
-Installations
--------------
-To compile the DPAA2_SEC PMD for Linux arm64 gcc target, run the
-following ``make`` command:
-
-.. code-block:: console
-
-   cd <DPDK-source-directory>
-   make config T=arm64-dpaa-linux-gcc install
 
 Enabling logs
 -------------
diff --git a/doc/guides/cryptodevs/dpaa_sec.rst b/doc/guides/cryptodevs/dpaa_sec.rst
index db3c8e9189..da14a68d9c 100644
--- a/doc/guides/cryptodevs/dpaa_sec.rst
+++ b/doc/guides/cryptodevs/dpaa_sec.rst
@@ -111,31 +111,6 @@  See :doc:`../platform/dpaa` for setup information
 
 - Follow the DPDK :ref:`Getting Started Guide for Linux <linux_gsg>` to setup the basic DPDK environment.
 
-Pre-Installation Configuration
-------------------------------
-
-Config File Options
-~~~~~~~~~~~~~~~~~~~
-
-Basic DPAA config file options are described in :ref:`dpaa_overview`.
-In addition to those, the following options can be modified in the ``config`` file
-to enable DPAA_SEC PMD.
-
-Please note that enabling debugging options may affect system performance.
-
-* ``CONFIG_RTE_LIBRTE_PMD_DPAA_SEC`` (default ``n``)
-  By default it is only enabled in defconfig_arm64-dpaa-* config.
-  Toggle compilation of the ``librte_pmd_dpaa_sec`` driver.
-
-Installations
--------------
-To compile the DPAA_SEC PMD for Linux arm64 gcc target, run the
-following ``make`` command:
-
-.. code-block:: console
-
-   cd <DPDK-source-directory>
-   make config T=arm64-dpaa-linux-gcc install
 
 Enabling logs
 -------------
diff --git a/doc/guides/cryptodevs/kasumi.rst b/doc/guides/cryptodevs/kasumi.rst
index 09a538f816..5770a60cb2 100644
--- a/doc/guides/cryptodevs/kasumi.rst
+++ b/doc/guides/cryptodevs/kasumi.rst
@@ -89,15 +89,6 @@  In order to enable this virtual crypto PMD, user must:
 
 * Build the multi buffer library (explained in Installation section).
 
-* Build DPDK as follows:
-
-.. code-block:: console
-
-	make config T=x86_64-native-linux-gcc
-	sed -i 's,\(CONFIG_RTE_LIBRTE_PMD_KASUMI\)=n,\1=y,' build/.config
-	make
-
-
 To use the PMD in an application, user must:
 
 * Call rte_vdev_init("crypto_kasumi") within the application.
@@ -117,7 +108,7 @@  Example:
 
 .. code-block:: console
 
-    ./l2fwd-crypto -l 1 -n 4 --vdev="crypto_kasumi,socket_id=0,max_nb_sessions=128" \
+    ./dpdk-l2fwd-crypto -l 1 -n 4 --vdev="crypto_kasumi,socket_id=0,max_nb_sessions=128" \
     -- -p 1 --cdev SW --chain CIPHER_ONLY --cipher_algo "kasumi-f8"
 
 Extra notes on KASUMI F9
diff --git a/doc/guides/cryptodevs/mvsam.rst b/doc/guides/cryptodevs/mvsam.rst
index 399fe37a67..6188c1248c 100644
--- a/doc/guides/cryptodevs/mvsam.rst
+++ b/doc/guides/cryptodevs/mvsam.rst
@@ -64,14 +64,6 @@  Limitations
 Installation
 ------------
 
-MVSAM CRYPTO PMD driver compilation is disabled by default due to external dependencies.
-Currently there are two driver specific compilation options in
-``config/common_base`` available:
-
-- ``CONFIG_RTE_LIBRTE_PMD_MVSAM_CRYPTO`` (default: ``n``)
-
-    Toggle compilation of the librte_pmd_mvsam driver.
-
 MVSAM CRYPTO PMD requires MUSDK built with EIP197 support thus following
 extra option must be passed to the library configuration script:
 
@@ -105,7 +97,7 @@  operation:
 
 .. code-block:: console
 
-   ./l2fwd-crypto --vdev=eth_mvpp2,iface=eth0 --vdev=crypto_mvsam -- \
+   ./dpdk-l2fwd-crypto --vdev=eth_mvpp2,iface=eth0 --vdev=crypto_mvsam -- \
      --cipher_op ENCRYPT --cipher_algo aes-cbc \
      --cipher_key 00:01:02:03:04:05:06:07:08:09:0a:0b:0c:0d:0e:0f  \
      --auth_op GENERATE --auth_algo sha1-hmac \
diff --git a/doc/guides/cryptodevs/nitrox.rst b/doc/guides/cryptodevs/nitrox.rst
index 85f5212b64..2f0565b49e 100644
--- a/doc/guides/cryptodevs/nitrox.rst
+++ b/doc/guides/cryptodevs/nitrox.rst
@@ -33,13 +33,6 @@  Limitations
 * 3DES Cipher Only combination is not supported.
 * Session-less APIs are not supported.
 
-Installation
-------------
-
-For compiling the Nitrox crypto PMD, please check if the
-CONFIG_RTE_LIBRTE_PMD_NITROX setting is set to `y` in config/common_base file.
-
-* ``CONFIG_RTE_LIBRTE_PMD_NITROX=y``
 
 Initialization
 --------------
diff --git a/doc/guides/cryptodevs/null.rst b/doc/guides/cryptodevs/null.rst
index c980e0ac84..aac5904b1d 100644
--- a/doc/guides/cryptodevs/null.rst
+++ b/doc/guides/cryptodevs/null.rst
@@ -67,5 +67,5 @@  Example:
 
 .. code-block:: console
 
-    ./l2fwd-crypto -l 1 -n 4 --vdev="crypto_null,socket_id=0,max_nb_sessions=128" \
+    ./dpdk-l2fwd-crypto -l 1 -n 4 --vdev="crypto_null,socket_id=0,max_nb_sessions=128" \
     -- -p 1 --cdev SW --chain CIPHER_ONLY --cipher_algo "null"
diff --git a/doc/guides/cryptodevs/octeontx.rst b/doc/guides/cryptodevs/octeontx.rst
index 4fa199e3c4..d813cb2974 100644
--- a/doc/guides/cryptodevs/octeontx.rst
+++ b/doc/guides/cryptodevs/octeontx.rst
@@ -59,14 +59,6 @@  Supported Asymmetric Crypto Algorithms
 * ``RTE_CRYPTO_ASYM_XFORM_RSA``
 * ``RTE_CRYPTO_ASYM_XFORM_MODEX``
 
-Config flags
-------------
-
-For compiling the OCTEON TX crypto poll mode driver, please check if the
-CONFIG_RTE_LIBRTE_PMD_OCTEONTX_CRYPTO setting is set to `y` in
-config/common_base file.
-
-* ``CONFIG_RTE_LIBRTE_PMD_OCTEONTX_CRYPTO=y``
 
 Compilation
 -----------
@@ -135,7 +127,7 @@  application:
 
 .. code-block:: console
 
-        ./test
+        ./dpdk-test
         RTE>>cryptodev_octeontx_autotest
 
 The asymmetric crypto operations on OCTEON TX crypto PMD may be verified by running the test
@@ -143,5 +135,5 @@  application:
 
 .. code-block:: console
 
-        ./test
+        ./dpdk-test
         RTE>>cryptodev_octeontx_asym_autotest
diff --git a/doc/guides/cryptodevs/octeontx2.rst b/doc/guides/cryptodevs/octeontx2.rst
index 432146db04..bb4af3a04d 100644
--- a/doc/guides/cryptodevs/octeontx2.rst
+++ b/doc/guides/cryptodevs/octeontx2.rst
@@ -70,10 +70,6 @@  Installation
 The OCTEON TX2 crypto PMD may be compiled natively on an OCTEON TX2 platform or
 cross-compiled on an x86 platform.
 
-Enable OCTEON TX2 crypto PMD in your config file:
-
-* ``CONFIG_RTE_LIBRTE_PMD_OCTEONTX2_CRYPTO=y``
-
 Refer to :doc:`../platform/octeontx2` for instructions to build your DPDK
 application.
 
@@ -148,7 +144,7 @@  application:
 
 .. code-block:: console
 
-    ./test
+    ./dpdk-test
     RTE>>cryptodev_octeontx2_autotest
 
 The asymmetric crypto operations on OCTEON TX2 crypto PMD may be verified by running the test
@@ -156,7 +152,7 @@  application:
 
 .. code-block:: console
 
-    ./test
+    ./dpdk-test
     RTE>>cryptodev_octeontx2_asym_autotest
 
 
diff --git a/doc/guides/cryptodevs/openssl.rst b/doc/guides/cryptodevs/openssl.rst
index 7407294813..ca0f0b43f3 100644
--- a/doc/guides/cryptodevs/openssl.rst
+++ b/doc/guides/cryptodevs/openssl.rst
@@ -58,8 +58,8 @@  Supported Asymmetric Crypto algorithms:
 Installation
 ------------
 
-To compile openssl PMD, it has to be enabled in the config/common_base file
-and appropriate openssl packages have to be installed in the build environment.
+To compile openssl PMD, appropriate openssl packages have to be installed
+in the build environment.
 
 The newest openssl library version is supported:
 
@@ -93,7 +93,7 @@  To verify real traffic l2fwd-crypto example can be used with this command:
 
 .. code-block:: console
 
-	sudo ./build/l2fwd-crypto -l 0-1 -n 4 --vdev "crypto_openssl"
+	sudo ./<build_dir>/examples/dpdk-l2fwd-crypto -l 0-1 -n 4 --vdev "crypto_openssl"
 	--vdev "crypto_openssl"-- -p 0x3 --chain CIPHER_HASH
 	--cipher_op ENCRYPT --cipher_algo AES_CBC
 	--cipher_key 00:01:02:03:04:05:06:07:08:09:0a:0b:0c:0d:0e:0f
diff --git a/doc/guides/cryptodevs/qat.rst b/doc/guides/cryptodevs/qat.rst
index e5d2cf4997..6714a7a8a2 100644
--- a/doc/guides/cryptodevs/qat.rst
+++ b/doc/guides/cryptodevs/qat.rst
@@ -207,27 +207,6 @@  Configuring and Building the DPDK QAT PMDs
 Further information on configuring, building and installing DPDK is described
 :doc:`here <../linux_gsg/build_dpdk>`.
 
-
-Quick instructions for QAT cryptodev PMD are as follows:
-
-.. code-block:: console
-
-	cd to the top-level DPDK directory
-	make defconfig
-	sed -i 's,\(CONFIG_RTE_LIBRTE_PMD_QAT_SYM\)=n,\1=y,' build/.config
-	or/and
-	sed -i 's,\(CONFIG_RTE_LIBRTE_PMD_QAT_ASYM\)=n,\1=y,' build/.config
-	make
-
-Quick instructions for QAT compressdev PMD are as follows:
-
-.. code-block:: console
-
-	cd to the top-level DPDK directory
-	make defconfig
-	make
-
-
 .. _building_qat_config:
 
 Build Configuration
@@ -237,38 +216,32 @@  These are the build configuration options affecting QAT, and their default value
 
 .. code-block:: console
 
-	CONFIG_RTE_LIBRTE_PMD_QAT=y
-	CONFIG_RTE_LIBRTE_PMD_QAT_SYM=n
-	CONFIG_RTE_LIBRTE_PMD_QAT_ASYM=n
-	CONFIG_RTE_PMD_QAT_MAX_PCI_DEVICES=48
-	CONFIG_RTE_PMD_QAT_COMP_IM_BUFFER_SIZE=65536
-
-CONFIG_RTE_LIBRTE_PMD_QAT must be enabled for any QAT PMD to be built.
+	RTE_PMD_QAT_MAX_PCI_DEVICES=48
+	RTE_PMD_QAT_COMP_IM_BUFFER_SIZE=65536
 
 Both QAT SYM PMD and QAT ASYM PMD have an external dependency on libcrypto, so are not
-built by default. CONFIG_RTE_LIBRTE_PMD_QAT_SYM/ASYM should be enabled to build them.
+built by default.
 
-The QAT compressdev PMD has no external dependencies, so needs no configuration
-options and is built by default.
+The QAT compressdev PMD has no external dependencies, so is built by default.
 
 The number of VFs per PF varies - see table below. If multiple QAT packages are
-installed on a platform then CONFIG_RTE_PMD_QAT_MAX_PCI_DEVICES should be
+installed on a platform then RTE_PMD_QAT_MAX_PCI_DEVICES should be
 adjusted to the number of VFs which the QAT common code will need to handle.
 
 .. Note::
 
         There are separate config items (not QAT-specific) for max cryptodevs
-        CONFIG_RTE_CRYPTO_MAX_DEVS and max compressdevs CONFIG_RTE_COMPRESS_MAX_DEVS,
+        RTE_CRYPTO_MAX_DEVS and max compressdevs RTE_COMPRESS_MAX_DEVS,
         if necessary these should be adjusted to handle the total of QAT and other
         devices which the process will use. In particular for crypto, where each
         QAT VF may expose two crypto devices, sym and asym, it may happen that the
         number of devices will be bigger than MAX_DEVS and the process will show an error
-        during PMD initialisation. To avoid this problem CONFIG_RTE_CRYPTO_MAX_DEVS may be
+        during PMD initialisation. To avoid this problem RTE_CRYPTO_MAX_DEVS may be
         increased or -w, pci-whitelist domain:bus:devid:func option may be used.
 
 
 QAT compression PMD needs intermediate buffers to support Deflate compression
-with Dynamic Huffman encoding. CONFIG_RTE_PMD_QAT_COMP_IM_BUFFER_SIZE
+with Dynamic Huffman encoding. RTE_PMD_QAT_COMP_IM_BUFFER_SIZE
 specifies the size of a single buffer, the PMD will allocate a multiple of these,
 plus some extra space for associated meta-data. For GEN2 devices, 20 buffers are
 allocated while for GEN1 devices, 12 buffers are allocated, plus 1472 bytes overhead.
@@ -483,7 +456,6 @@  To complete the installation follow the instructions in
       insmod ./drivers/crypto/qat/qat_common/intel_qat.ko
       insmod ./drivers/crypto/qat/qat_dh895xcc/qat_dh895xcc.ko
 
-
 .. Note::
 
    If you see the following warning in ``/var/log/messages`` it can be ignored:
@@ -644,7 +616,7 @@  e.g. for the C62x device::
 
     cd to the top-level DPDK directory
     modprobe uio
-    insmod ./build/kmod/igb_uio.ko
+    insmod ./<build_dir>/kernel/linux/igb_uio/igb_uio.ko
     echo "8086 37c9" > /sys/bus/pci/drivers/igb_uio/new_id
     lspci -vvd:37c9
 
@@ -660,27 +632,20 @@  Testing
 
 QAT SYM crypto PMD can be tested by running the test application::
 
-    make defconfig
-    make -j
-    cd ./build/app
-    ./test -l1 -n1 -w <your qat bdf>
+    cd ./<build_dir>/app/test
+    ./dpdk-test -l1 -n1 -w <your qat bdf>
     RTE>>cryptodev_qat_autotest
 
 QAT ASYM crypto PMD can be tested by running the test application::
 
-    make defconfig
-    make -j
-    cd ./build/app
-    ./test -l1 -n1 -w <your qat bdf>
+    cd ./<build_dir>/app/test
+    ./dpdk-test -l1 -n1 -w <your qat bdf>
     RTE>>cryptodev_qat_asym_autotest
 
 QAT compression PMD can be tested by running the test application::
 
-    make defconfig
-    sed -i 's,\(CONFIG_RTE_COMPRESSDEV_TEST\)=n,\1=y,' build/.config
-    make -j
-    cd ./build/app
-    ./test -l1 -n1 -w <your qat bdf>
+    cd ./<build_dir>/app/test
+    ./dpdk-test -l1 -n1 -w <your qat bdf>
     RTE>>compressdev_autotest
 
 
@@ -704,7 +669,7 @@  the process cmdline, e.g. using any of the following::
 
     The global RTE_LOG_DP_LEVEL overrides data-path trace so must be set to
     RTE_LOG_DEBUG to see all the trace. This variable is in config/rte_config.h
-    for meson build and config/common_base for gnu make.
+    for meson build.
     Also the dynamic global log level overrides both sets of trace, so e.g. no
     QAT trace would display in this case::
 
diff --git a/doc/guides/cryptodevs/scheduler.rst b/doc/guides/cryptodevs/scheduler.rst
index 7004ca431a..ee23b25b73 100644
--- a/doc/guides/cryptodevs/scheduler.rst
+++ b/doc/guides/cryptodevs/scheduler.rst
@@ -32,14 +32,6 @@  Limitations
   is enabled.
 
 
-Installation
-------------
-
-To build DPDK with CRYTPO_SCHEDULER_PMD the user is required to set
-CONFIG_RTE_LIBRTE_PMD_CRYPTO_SCHEDULER=y in config/common_base, and
-recompile DPDK
-
-
 Initialization
 --------------
 
diff --git a/doc/guides/cryptodevs/snow3g.rst b/doc/guides/cryptodevs/snow3g.rst
index e0cddc2d77..13341c39c4 100644
--- a/doc/guides/cryptodevs/snow3g.rst
+++ b/doc/guides/cryptodevs/snow3g.rst
@@ -88,14 +88,6 @@  In order to enable this virtual crypto PMD, user must:
 
 * Build the multi buffer library (explained in Installation section).
 
-* Build DPDK as follows:
-
-.. code-block:: console
-
-	make config T=x86_64-native-linux-gcc
-	sed -i 's,\(CONFIG_RTE_LIBRTE_PMD_SNOW3G\)=n,\1=y,' build/.config
-	make
-
 To use the PMD in an application, user must:
 
 * Call rte_vdev_init("crypto_snow3g") within the application.
@@ -115,5 +107,5 @@  Example:
 
 .. code-block:: console
 
-    ./l2fwd-crypto -l 1 -n 4 --vdev="crypto_snow3g,socket_id=0,max_nb_sessions=128" \
+    ./dpdk-l2fwd-crypto -l 1 -n 4 --vdev="crypto_snow3g,socket_id=0,max_nb_sessions=128" \
     -- -p 1 --cdev SW --chain CIPHER_ONLY --cipher_algo "snow3g-uea2"
diff --git a/doc/guides/cryptodevs/virtio.rst b/doc/guides/cryptodevs/virtio.rst
index 2c46bda866..83d8e32397 100644
--- a/doc/guides/cryptodevs/virtio.rst
+++ b/doc/guides/cryptodevs/virtio.rst
@@ -83,27 +83,17 @@  The unit test cases can be tested as below:
 .. code-block:: console
 
     reserve enough huge pages
-    cd to the top-level DPDK directory
-    export RTE_TARGET=x86_64-native-linux-gcc
-    export RTE_SDK=`pwd`
-    cd to app/test
-    type the command "make" to compile
-    run the tests with "./test"
-    type the command "cryptodev_virtio_autotest" to test
+    cd to <build_dir>
+    meson test cryptodev_virtio_autotest
 
 The performance can be tested as below:
 
 .. code-block:: console
 
     reserve enough huge pages
-    cd to the top-level DPDK directory
-    export RTE_TARGET=x86_64-native-linux-gcc
-    export RTE_SDK=`pwd`
-    cd to app/test-crypto-perf
-    type the command "make" to compile
-    run the tests with the following command:
-
-    ./dpdk-test-crypto-perf -l 0,1 -- --devtype crypto_virtio \
+    cd to <build_dir>
+
+    ./app/dpdk-test-crypto-perf -l 0,1 -- --devtype crypto_virtio \
         --ptest throughput --optype cipher-then-auth --cipher-algo aes-cbc \
         --cipher-op encrypt --cipher-key-sz 16 --auth-algo sha1-hmac \
         --auth-op generate --auth-key-sz 64 --digest-sz 12 \
diff --git a/doc/guides/cryptodevs/zuc.rst b/doc/guides/cryptodevs/zuc.rst
index 9b51ba141d..907840ef05 100644
--- a/doc/guides/cryptodevs/zuc.rst
+++ b/doc/guides/cryptodevs/zuc.rst
@@ -88,14 +88,6 @@  In order to enable this virtual crypto PMD, user must:
 
 * Build the multi buffer library (explained in Installation section).
 
-* Build DPDK as follows:
-
-.. code-block:: console
-
-	make config T=x86_64-native-linux-gcc
-	sed -i 's,\(CONFIG_RTE_LIBRTE_PMD_ZUC\)=n,\1=y,' build/.config
-	make
-
 To use the PMD in an application, user must:
 
 * Call rte_vdev_init("crypto_zuc") within the application.
@@ -115,5 +107,5 @@  Example:
 
 .. code-block:: console
 
-    ./l2fwd-crypto -l 1 -n 4 --vdev="crypto_zuc,socket_id=0,max_nb_sessions=128" \
+    ./dpdk-l2fwd-crypto -l 1 -n 4 --vdev="crypto_zuc,socket_id=0,max_nb_sessions=128" \
     -- -p 1 --cdev SW --chain CIPHER_ONLY --cipher_algo "zuc-eea3"