[v2] doc: add NASM installation steps
diff mbox series

Message ID 1590052512-162500-1-git-send-email-pablo.de.lara.guarch@intel.com
State Accepted, archived
Delegated to: Thomas Monjalon
Headers show
Series
  • [v2] doc: add NASM installation steps
Related show

Checks

Context Check Description
ci/travis-robot success Travis build: passed
ci/Intel-compilation fail Compilation issues
ci/checkpatch success coding style OK

Commit Message

De Lara Guarch, Pablo May 21, 2020, 9:15 a.m. UTC
The intel-ipsec-mb library requires NASM as a dependency.
Steps on how to get and install NASM are added on the documentation
of the crypto PMDs which requires the library.

Bugzilla ID: 417
Cc: stable@dpdk.org

Signed-off-by: Pablo de Lara <pablo.de.lara.guarch@intel.com>
---

v2:
- Added Bugzilla ID
- Modified links to fix Doxygen warnings

 doc/guides/cryptodevs/aesni_gcm.rst | 14 ++++++++++++++
 doc/guides/cryptodevs/aesni_mb.rst  | 14 ++++++++++++++
 doc/guides/cryptodevs/kasumi.rst    | 14 ++++++++++++++
 doc/guides/cryptodevs/snow3g.rst    | 14 ++++++++++++++
 doc/guides/cryptodevs/zuc.rst       | 14 ++++++++++++++
 5 files changed, 70 insertions(+)

Comments

Kevin Traynor May 21, 2020, 9:27 a.m. UTC | #1
On 21/05/2020 10:15, Pablo de Lara wrote:
> The intel-ipsec-mb library requires NASM as a dependency.
> Steps on how to get and install NASM are added on the documentation
> of the crypto PMDs which requires the library.
> 
> Bugzilla ID: 417
> Cc: stable@dpdk.org
> 
> Signed-off-by: Pablo de Lara <pablo.de.lara.guarch@intel.com>

Acked-by: Kevin Traynor <ktraynor@redhat.com>
Thomas Monjalon May 24, 2020, 4:56 p.m. UTC | #2
21/05/2020 11:27, Kevin Traynor:
> On 21/05/2020 10:15, Pablo de Lara wrote:
> > The intel-ipsec-mb library requires NASM as a dependency.
> > Steps on how to get and install NASM are added on the documentation
> > of the crypto PMDs which requires the library.
> > 
> > Bugzilla ID: 417
> > Cc: stable@dpdk.org
> > 
> > Signed-off-by: Pablo de Lara <pablo.de.lara.guarch@intel.com>
> 
> Acked-by: Kevin Traynor <ktraynor@redhat.com>

Applied, thanks

Patch
diff mbox series

diff --git a/doc/guides/cryptodevs/aesni_gcm.rst b/doc/guides/cryptodevs/aesni_gcm.rst
index 7dfd0ca99..74e0de63a 100644
--- a/doc/guides/cryptodevs/aesni_gcm.rst
+++ b/doc/guides/cryptodevs/aesni_gcm.rst
@@ -50,6 +50,20 @@  can be downloaded in `<https://github.com/01org/intel-ipsec-mb/archive/v0.54.zip
     make
     make install
 
+The library requires NASM to be built. Depending on the library version, it might
+require a minimum NASM version (e.g. v0.54 requires at least NASM 2.14).
+
+NASM is packaged for different OS. However, on some OS the version is too old,
+so a manual installation is required. In that case, NASM can be downloaded from
+`NASM website <https://www.nasm.us/pub/nasm/releasebuilds/?C=M;O=D>`_.
+Once it is downloaded, extract it and follow these steps:
+
+.. code-block:: console
+
+    ./configure
+    make
+    make install
+
 .. note::
 
    Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.
diff --git a/doc/guides/cryptodevs/aesni_mb.rst b/doc/guides/cryptodevs/aesni_mb.rst
index a2c3a8481..cc64f1243 100644
--- a/doc/guides/cryptodevs/aesni_mb.rst
+++ b/doc/guides/cryptodevs/aesni_mb.rst
@@ -75,6 +75,20 @@  can be downloaded from `<https://github.com/01org/intel-ipsec-mb/archive/v0.54.z
     make
     make install
 
+The library requires NASM to be built. Depending on the library version, it might
+require a minimum NASM version (e.g. v0.54 requires at least NASM 2.14).
+
+NASM is packaged for different OS. However, on some OS the version is too old,
+so a manual installation is required. In that case, NASM can be downloaded from
+`NASM website <https://www.nasm.us/pub/nasm/releasebuilds/?C=M;O=D>`_.
+Once it is downloaded, extract it and follow these steps:
+
+.. code-block:: console
+
+    ./configure
+    make
+    make install
+
 .. note::
 
    Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.
diff --git a/doc/guides/cryptodevs/kasumi.rst b/doc/guides/cryptodevs/kasumi.rst
index edbc1c699..09a538f81 100644
--- a/doc/guides/cryptodevs/kasumi.rst
+++ b/doc/guides/cryptodevs/kasumi.rst
@@ -47,6 +47,20 @@  on their system before building DPDK:
     make
     make install
 
+The library requires NASM to be built. Depending on the library version, it might
+require a minimum NASM version (e.g. v0.54 requires at least NASM 2.14).
+
+NASM is packaged for different OS. However, on some OS the version is too old,
+so a manual installation is required. In that case, NASM can be downloaded from
+`NASM website <https://www.nasm.us/pub/nasm/releasebuilds/?C=M;O=D>`_.
+Once it is downloaded, extract it and follow these steps:
+
+.. code-block:: console
+
+    ./configure
+    make
+    make install
+
 .. note::
 
    Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.
diff --git a/doc/guides/cryptodevs/snow3g.rst b/doc/guides/cryptodevs/snow3g.rst
index b715b4602..e0cddc2d7 100644
--- a/doc/guides/cryptodevs/snow3g.rst
+++ b/doc/guides/cryptodevs/snow3g.rst
@@ -46,6 +46,20 @@  on their system before building DPDK:
     make
     make install
 
+The library requires NASM to be built. Depending on the library version, it might
+require a minimum NASM version (e.g. v0.54 requires at least NASM 2.14).
+
+NASM is packaged for different OS. However, on some OS the version is too old,
+so a manual installation is required. In that case, NASM can be downloaded from
+`NASM website <https://www.nasm.us/pub/nasm/releasebuilds/?C=M;O=D>`_.
+Once it is downloaded, extract it and follow these steps:
+
+.. code-block:: console
+
+    ./configure
+    make
+    make install
+
 .. note::
 
    Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.
diff --git a/doc/guides/cryptodevs/zuc.rst b/doc/guides/cryptodevs/zuc.rst
index c384f3d9e..9b51ba141 100644
--- a/doc/guides/cryptodevs/zuc.rst
+++ b/doc/guides/cryptodevs/zuc.rst
@@ -46,6 +46,20 @@  on their system before building DPDK:
     make
     make install
 
+The library requires NASM to be built. Depending on the library version, it might
+require a minimum NASM version (e.g. v0.54 requires at least NASM 2.14).
+
+NASM is packaged for different OS. However, on some OS the version is too old,
+so a manual installation is required. In that case, NASM can be downloaded from
+`NASM website <https://www.nasm.us/pub/nasm/releasebuilds/?C=M;O=D>`_.
+Once it is downloaded, extract it and follow these steps:
+
+.. code-block:: console
+
+    ./configure
+    make
+    make install
+
 .. note::
 
    Compilation of the Multi-Buffer library is broken when GCC < 5.0, if library <= v0.53.