[2/2] ci: use meson 0.47.1
diff mbox series

Message ID 20200109125916.32073-2-david.marchand@redhat.com
State Accepted, archived
Delegated to: David Marchand
Headers show
Series
  • [1/2] build: fix libm detection in meson
Related show

Checks

Context Check Description
ci/Intel-compilation success Compilation OK
ci/travis-robot success Travis build: passed
ci/checkpatch success coding style OK

Commit Message

David Marchand Jan. 9, 2020, 12:59 p.m. UTC
meson 0.53.0 has a compatibility issue [1] with the python 3.5.2 that comes
in Ubuntu 16.04.
On the other hand, the minimal version supported in dpdk is 0.47.1.

Stick to this version to avoid getting hit by regressions in meson latest
shiny release.

1: https://github.com/mesonbuild/meson/issues/6427

Cc: stable@dpdk.org

Signed-off-by: David Marchand <david.marchand@redhat.com>
---
 .ci/linux-setup.sh | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Bruce Richardson Jan. 9, 2020, 1:09 p.m. UTC | #1
On Thu, Jan 09, 2020 at 01:59:16PM +0100, David Marchand wrote:
> meson 0.53.0 has a compatibility issue [1] with the python 3.5.2 that comes
> in Ubuntu 16.04.
> On the other hand, the minimal version supported in dpdk is 0.47.1.
> 
> Stick to this version to avoid getting hit by regressions in meson latest
> shiny release.
> 
> 1: https://github.com/mesonbuild/meson/issues/6427
> 
> Cc: stable@dpdk.org
> 
> Signed-off-by: David Marchand <david.marchand@redhat.com>
> ---
>  .ci/linux-setup.sh | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/.ci/linux-setup.sh b/.ci/linux-setup.sh
> index dfb9d4a20..38bb88e15 100755
> --- a/.ci/linux-setup.sh
> +++ b/.ci/linux-setup.sh
> @@ -1,7 +1,7 @@
>  #!/bin/sh -xe
>  
>  # need to install as 'root' since some of the unit tests won't run without it
> -sudo python3 -m pip install --upgrade meson
> +sudo python3 -m pip install --upgrade 'meson==0.47.1'
>  
Acked-by: Bruce Richardson <bruce.richardson@intel.com>
Aaron Conole Jan. 9, 2020, 2:16 p.m. UTC | #2
David Marchand <david.marchand@redhat.com> writes:

> meson 0.53.0 has a compatibility issue [1] with the python 3.5.2 that comes
> in Ubuntu 16.04.
> On the other hand, the minimal version supported in dpdk is 0.47.1.
>
> Stick to this version to avoid getting hit by regressions in meson latest
> shiny release.
>
> 1: https://github.com/mesonbuild/meson/issues/6427
>
> Cc: stable@dpdk.org
>
> Signed-off-by: David Marchand <david.marchand@redhat.com>
> ---

Acked-by: Aaron Conole <aconole@redhat.com>

Patch
diff mbox series

diff --git a/.ci/linux-setup.sh b/.ci/linux-setup.sh
index dfb9d4a20..38bb88e15 100755
--- a/.ci/linux-setup.sh
+++ b/.ci/linux-setup.sh
@@ -1,7 +1,7 @@ 
 #!/bin/sh -xe
 
 # need to install as 'root' since some of the unit tests won't run without it
-sudo python3 -m pip install --upgrade meson
+sudo python3 -m pip install --upgrade 'meson==0.47.1'
 
 # setup hugepages
 cat /proc/meminfo