[2/3] doc: add Mellanox EN support

Message ID 20190130075321.24466-2-yskoh@mellanox.com
State Accepted, archived
Delegated to: Shahaf Shuler
Headers show
Series
  • [1/3] doc: add mlx5 note for Bluefield build configuration
Related show

Checks

Context Check Description
ci/Intel-compilation success Compilation OK
ci/checkpatch success coding style OK

Commit Message

Yongseok Koh Jan. 30, 2019, 7:53 a.m.
Mellanox EN package is supported along with Mellanox OFED. Mellanox EN is
distriubuted for Ethernet users.

Signed-off-by: Yongseok Koh <yskoh@mellanox.com>
---
 doc/guides/nics/mlx5.rst | 30 ++++++++++++++++--------------
 1 file changed, 16 insertions(+), 14 deletions(-)

Patch

diff --git a/doc/guides/nics/mlx5.rst b/doc/guides/nics/mlx5.rst
index 62de860d0a..af102f15a0 100644
--- a/doc/guides/nics/mlx5.rst
+++ b/doc/guides/nics/mlx5.rst
@@ -559,7 +559,7 @@  DPDK and must be installed separately:
 
 - **Firmware update**
 
-  Mellanox OFED releases include firmware updates for
+  Mellanox OFED/EN releases include firmware updates for
   ConnectX-4/ConnectX-5/ConnectX-6/Bluefield adapters.
 
   Because each release provides new features, these updates must be applied to
@@ -574,7 +574,7 @@  Installation
 ~~~~~~~~~~~~
 
 Either RDMA Core library with a recent enough Linux kernel release
-(recommended) or Mellanox OFED, which provides compatibility with older
+(recommended) or Mellanox OFED/EN, which provides compatibility with older
 releases.
 
 RMDA Core with Linux Kernel
@@ -604,10 +604,10 @@  thanks to these environment variables:
    - ``EXTRA_LDFLAGS=-L/path/to/rdma-core/build/lib``
    - ``PKG_CONFIG_PATH=/path/to/rdma-core/build/lib/pkgconfig``
 
-Mellanox OFED
-^^^^^^^^^^^^^
+Mellanox OFED/EN
+^^^^^^^^^^^^^^^^
 
-- Mellanox OFED version: **4.4, 4.5**.
+- Mellanox OFED version: **4.4, 4.5** / Mellanox EN version: **4.5**
 - firmware version:
 
   - ConnectX-4: **12.21.1000** and above.
@@ -623,14 +623,16 @@  managers on most distributions, this PMD requires Ethernet extensions that
 may not be supported at the moment (this is a work in progress).
 
 `Mellanox OFED
-<http://www.mellanox.com/page/products_dyn?product_family=26&mtag=linux>`__
-includes the necessary support and should be used in the meantime. For DPDK,
+<http://www.mellanox.com/page/products_dyn?product_family=26&mtag=linux>`__ and
+`Mellanox EN
+<http://www.mellanox.com/page/products_dyn?product_family=27&mtag=linux>`__
+include the necessary support and should be used in the meantime. For DPDK,
 only libibverbs, libmlx5, mlnx-ofed-kernel packages and firmware updates are
 required from that distribution.
 
 .. note::
 
-   Several versions of Mellanox OFED are available. Installing the version
+   Several versions of Mellanox OFED/EN are available. Installing the version
    this DPDK release was developed and tested against is strongly
    recommended. Please check the `prerequisites`_.
 
@@ -670,14 +672,14 @@  Supported NICs
 * Mellanox(R) ConnectX(R)-5 100G MCX556A-ECAT (2x100G)
 * Mellanox(R) ConnectX(R)-5 Ex EN 100G MCX516A-CDAT (2x100G)
 
-Quick Start Guide on OFED
--------------------------
+Quick Start Guide on OFED/EN
+----------------------------
 
-1. Download latest Mellanox OFED. For more info check the  `prerequisites`_.
+1. Download latest Mellanox OFED/EN. For more info check the  `prerequisites`_.
 
 
 2. Install the required libraries and kernel modules either by installing
-   only the required set, or by installing the entire Mellanox OFED:
+   only the required set, or by installing the entire Mellanox OFED/EN:
 
    .. code-block:: console
 
@@ -854,8 +856,8 @@  ConnectX-4/ConnectX-5/ConnectX-6/Bluefield devices managed by librte_pmd_mlx5.
 
       modprobe -a ib_uverbs mlx5_core mlx5_ib
 
-   Alternatively if MLNX_OFED is fully installed, the following script can
-   be run:
+   Alternatively if MLNX_OFED/MLNX_EN is fully installed, the following script
+   can be run:
 
    .. code-block:: console