[dpdk-dev,v2,2/2] doc: update mlx PMD required OFED version

Message ID 1a9b089fed79bf6b22e1ab81748eeaa5a543890b.1517727898.git.shahafs@mellanox.com
State Superseded, archived
Headers show

Checks

Context Check Description
ci/Intel-compilation success Compilation OK
ci/checkpatch success coding style OK

Commit Message

Shahaf Shuler Feb. 4, 2018, 7:08 a.m.
Signed-off-by: Shahaf Shuler <shahafs@mellanox.com>
---

On v2:
 - Updated the OFED version for mlx4 guide as well.

---
 doc/guides/nics/mlx4.rst | 2 +-
 doc/guides/nics/mlx5.rst | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Nélio Laranjeiro Feb. 5, 2018, 7:44 a.m. | #1
On Sun, Feb 04, 2018 at 09:08:06AM +0200, Shahaf Shuler wrote:
> Signed-off-by: Shahaf Shuler <shahafs@mellanox.com>
> ---
> 
> On v2:
>  - Updated the OFED version for mlx4 guide as well.
> 
> ---
>  doc/guides/nics/mlx4.rst | 2 +-
>  doc/guides/nics/mlx5.rst | 4 ++--
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/doc/guides/nics/mlx4.rst b/doc/guides/nics/mlx4.rst
> index 88161781c..13cc6ec8a 100644
> --- a/doc/guides/nics/mlx4.rst
> +++ b/doc/guides/nics/mlx4.rst
> @@ -219,7 +219,7 @@ Current RDMA core package and Linux kernel (recommended)
>  Mellanox OFED as a fallback
>  ~~~~~~~~~~~~~~~~~~~~~~~~~~~
>  
> -- `Mellanox OFED`_ version: **4.2**.
> +- `Mellanox OFED`_ version: **4.2, 4.3**.
>  - firmware version: **2.42.5000** and above.
>  
>  .. _`Mellanox OFED`: http://www.mellanox.com/page/products_dyn?product_family=26&mtag=linux_sw_drivers
> diff --git a/doc/guides/nics/mlx5.rst b/doc/guides/nics/mlx5.rst
> index a9e4bf51a..b2376363b 100644
> --- a/doc/guides/nics/mlx5.rst
> +++ b/doc/guides/nics/mlx5.rst
> @@ -131,7 +131,7 @@ Limitations
>  - A multi segment packet must have less than 6 segments in case the Tx burst function
>    is set to multi-packet send or Enhanced multi-packet send. Otherwise it must have
>    less than 50 segments.
> -- Count action for RTE flow is only supported in Mellanox OFED 4.2.
> +- Count action for RTE flow is only supported in Mellanox OFED 4.2 and above.

Is this really useful to copy the Mellanox OFED version already present
in the Mellanox OFED section?

I would suggest to highlight the *only supported in Mellanox OFED*
in this documentation, and maybe by setting a internal link to the
Mellaox OFED installation section.

>  - Flows with a VXLAN Network Identifier equal (or ends to be equal)
>    to 0 are not supported.
>  - VXLAN TSO and checksum offloads are not supported on VM.
> @@ -392,7 +392,7 @@ RMDA Core with Linux Kernel
>  Mellanox OFED
>  ^^^^^^^^^^^^^
>  
> -- Mellanox OFED version: **4.2**.
> +- Mellanox OFED version: **4.2, 4.3**.
>  - firmware version:
>  
>    - ConnectX-4: **12.21.1000** and above.
> -- 
> 2.12.0

Patch

diff --git a/doc/guides/nics/mlx4.rst b/doc/guides/nics/mlx4.rst
index 88161781c..13cc6ec8a 100644
--- a/doc/guides/nics/mlx4.rst
+++ b/doc/guides/nics/mlx4.rst
@@ -219,7 +219,7 @@  Current RDMA core package and Linux kernel (recommended)
 Mellanox OFED as a fallback
 ~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
-- `Mellanox OFED`_ version: **4.2**.
+- `Mellanox OFED`_ version: **4.2, 4.3**.
 - firmware version: **2.42.5000** and above.
 
 .. _`Mellanox OFED`: http://www.mellanox.com/page/products_dyn?product_family=26&mtag=linux_sw_drivers
diff --git a/doc/guides/nics/mlx5.rst b/doc/guides/nics/mlx5.rst
index a9e4bf51a..b2376363b 100644
--- a/doc/guides/nics/mlx5.rst
+++ b/doc/guides/nics/mlx5.rst
@@ -131,7 +131,7 @@  Limitations
 - A multi segment packet must have less than 6 segments in case the Tx burst function
   is set to multi-packet send or Enhanced multi-packet send. Otherwise it must have
   less than 50 segments.
-- Count action for RTE flow is only supported in Mellanox OFED 4.2.
+- Count action for RTE flow is only supported in Mellanox OFED 4.2 and above.
 - Flows with a VXLAN Network Identifier equal (or ends to be equal)
   to 0 are not supported.
 - VXLAN TSO and checksum offloads are not supported on VM.
@@ -392,7 +392,7 @@  RMDA Core with Linux Kernel
 Mellanox OFED
 ^^^^^^^^^^^^^
 
-- Mellanox OFED version: **4.2**.
+- Mellanox OFED version: **4.2, 4.3**.
 - firmware version:
 
   - ConnectX-4: **12.21.1000** and above.