[dpdk-dev,3/3] doc: remove ABI changes in igb_uio

Message ID 1485243248-27082-4-git-send-email-jianfeng.tan@intel.com
State Changes Requested, archived
Delegated to: Thomas Monjalon
Headers show

Checks

Context Check Description
ci/Intel compilation fail apply patch file failure
ci/checkpatch success coding style OK

Commit Message

Jianfeng Tan Jan. 24, 2017, 7:34 a.m.
We announced ABI changes to remove iomem and ioport mapping in
igb_uio. But it has potential backward compatibility issue: cannot
run old version DPDK on modified igb_uio.

The purpose of this changes was to fix a bug: when DPDK app crashes,
those devices by igb_uio are not stopped either DPDK PMD driver or
igb_uio driver. We need to figure out new way to fix this bug.

Fixes: 3bac1dbc1ed ("doc: announce iomem and ioport removal from igb_uio")

Suggested-by: Stephen Hemminger <stephen@networkplumber.org>
Signed-off-by: Jianfeng Tan <jianfeng.tan@intel.com>
---
 doc/guides/rel_notes/deprecation.rst | 5 -----
 1 file changed, 5 deletions(-)

Comments

Ferruh Yigit Jan. 24, 2017, 1:35 p.m. | #1
On 1/24/2017 7:34 AM, Jianfeng Tan wrote:
> We announced ABI changes to remove iomem and ioport mapping in
> igb_uio. But it has potential backward compatibility issue: cannot
> run old version DPDK on modified igb_uio.
> 
> The purpose of this changes was to fix a bug: when DPDK app crashes,
> those devices by igb_uio are not stopped either DPDK PMD driver or
> igb_uio driver. We need to figure out new way to fix this bug.

Hi Jianfeng,

I believe it would be good to fix this potential defect.

Is "remove iomem and ioport" a must for that fix? If so, I suggest
re-think about it.

If I see correctly, dpdk1.8 and older uses igb_uio iomem files. So
backward compatibility is the possible issue for dpdk1.8 and older.
Since v1.8 two years old, I would prefer fixing defect instead of
keeping that backward compatibility.

Jianfeng, Thomas,

What do you think postponing this deprecation notice to next release,
instead of removing it, and discuss more?


And overall, if "remove iomem and ioport" is not a must for this fix, no
problem to remove deprecation notice.

Thanks,
ferruh


> 
> Fixes: 3bac1dbc1ed ("doc: announce iomem and ioport removal from igb_uio")
> 
> Suggested-by: Stephen Hemminger <stephen@networkplumber.org>
> Signed-off-by: Jianfeng Tan <jianfeng.tan@intel.com>
> ---
>  doc/guides/rel_notes/deprecation.rst | 5 -----
>  1 file changed, 5 deletions(-)
> 
> diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
> index 755dc65..0f039dd 100644
> --- a/doc/guides/rel_notes/deprecation.rst
> +++ b/doc/guides/rel_notes/deprecation.rst
> @@ -8,11 +8,6 @@ API and ABI deprecation notices are to be posted here.
>  Deprecation Notices
>  -------------------
>  
> -* igb_uio: iomem mapping and sysfs files created for iomem and ioport in
> -  igb_uio will be removed, because we are able to detect these from what Linux
> -  has exposed, like the way we have done with uio-pci-generic. This change
> -  targets release 17.02.
> -
>  * ABI/API changes are planned for 17.02: ``rte_device``, ``rte_driver`` will be
>    impacted because of introduction of a new ``rte_bus`` hierarchy. This would
>    also impact the way devices are identified by EAL. A bus-device-driver model
>
Thomas Monjalon Jan. 30, 2017, 5:52 p.m. | #2
2017-01-24 13:35, Ferruh Yigit:
> On 1/24/2017 7:34 AM, Jianfeng Tan wrote:
> > We announced ABI changes to remove iomem and ioport mapping in
> > igb_uio. But it has potential backward compatibility issue: cannot
> > run old version DPDK on modified igb_uio.
> > 
> > The purpose of this changes was to fix a bug: when DPDK app crashes,
> > those devices by igb_uio are not stopped either DPDK PMD driver or
> > igb_uio driver. We need to figure out new way to fix this bug.
> 
> Hi Jianfeng,
> 
> I believe it would be good to fix this potential defect.
> 
> Is "remove iomem and ioport" a must for that fix? If so, I suggest
> re-think about it.
> 
> If I see correctly, dpdk1.8 and older uses igb_uio iomem files. So
> backward compatibility is the possible issue for dpdk1.8 and older.
> Since v1.8 two years old, I would prefer fixing defect instead of
> keeping that backward compatibility.
> 
> Jianfeng, Thomas,
> 
> What do you think postponing this deprecation notice to next release,
> instead of removing it, and discuss more?
> 
> 
> And overall, if "remove iomem and ioport" is not a must for this fix, no
> problem to remove deprecation notice.

I have no strong opinion here.
Jianfeng, do you agree with Ferruh?
Jianfeng Tan Feb. 1, 2017, 7:24 a.m. | #3
On 1/31/2017 1:52 AM, Thomas Monjalon wrote:
> 2017-01-24 13:35, Ferruh Yigit:
>> On 1/24/2017 7:34 AM, Jianfeng Tan wrote:
>>> We announced ABI changes to remove iomem and ioport mapping in
>>> igb_uio. But it has potential backward compatibility issue: cannot
>>> run old version DPDK on modified igb_uio.
>>>
>>> The purpose of this changes was to fix a bug: when DPDK app crashes,
>>> those devices by igb_uio are not stopped either DPDK PMD driver or
>>> igb_uio driver. We need to figure out new way to fix this bug.
>> Hi Jianfeng,
>>
>> I believe it would be good to fix this potential defect.
>>
>> Is "remove iomem and ioport" a must for that fix? If so, I suggest
>> re-think about it.
>>
>> If I see correctly, dpdk1.8 and older uses igb_uio iomem files. So
>> backward compatibility is the possible issue for dpdk1.8 and older.
>> Since v1.8 two years old, I would prefer fixing defect instead of
>> keeping that backward compatibility.
>>
>> Jianfeng, Thomas,
>>
>> What do you think postponing this deprecation notice to next release,
>> instead of removing it, and discuss more?
>>
>>
>> And overall, if "remove iomem and ioport" is not a must for this fix, no
>> problem to remove deprecation notice.
> I have no strong opinion here.
> Jianfeng, do you agree with Ferruh?

Hi Ferruh & Thomas,

I agree wit Ferruh to postpone this deprecation notice.

In another thread, we discussed the possibility to fix this problem 
without the deprecation. But I have no time to verify it in this release 
cycle. Let's postpone it then.

Thanks,
Jianfeng

Patch

diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
index 755dc65..0f039dd 100644
--- a/doc/guides/rel_notes/deprecation.rst
+++ b/doc/guides/rel_notes/deprecation.rst
@@ -8,11 +8,6 @@  API and ABI deprecation notices are to be posted here.
 Deprecation Notices
 -------------------
 
-* igb_uio: iomem mapping and sysfs files created for iomem and ioport in
-  igb_uio will be removed, because we are able to detect these from what Linux
-  has exposed, like the way we have done with uio-pci-generic. This change
-  targets release 17.02.
-
 * ABI/API changes are planned for 17.02: ``rte_device``, ``rte_driver`` will be
   impacted because of introduction of a new ``rte_bus`` hierarchy. This would
   also impact the way devices are identified by EAL. A bus-device-driver model